Nux!


Home » Stella » Report a problem or request a feature » vlc-core and libdvbpsi.so.7 dependency (dependency problem with updated EPEL libdvbpsi-1.3.0-3.el7.x86_64)
vlc-core and libdvbpsi.so.7 dependency [message #3769] Wed, 25 January 2017 16:39 Go to next message
cjatl404 is currently offline  cjatl404
Messages: 2
Registered: January 2017
Junior Member
I started getting the following error a few weeks ago when running my yum update:

# yum -y update
Loaded plugins: fastestmirror, langpacks
Loading mirror speeds from cached hostfile
* base: centos.mia.host-engine.com
* epel: mirror.mrjester.net
* extras: mirror.datto.com
* updates: repo1.dal.innoscale.net
Resolving Dependencies
--> Running transaction check
---> Package libdvbpsi.x86_64 0:0.2.2-3.el7.nux will be updated
--> Processing Dependency: libdvbpsi.so.7()(64bit) for package: 1:vlc-core-2.2.2-4.el7.nux.x86_64
---> Package libdvbpsi.x86_64 0:1.3.0-3.el7 will be an update
--> Finished Dependency Resolution
Error: Package: 1:vlc-core-2.2.2-4.el7.nux.x86_64 (@nux-dextop)
Requires: libdvbpsi.so.7()(64bit)
Removing: libdvbpsi-0.2.2-3.el7.nux.x86_64 (@nux-dextop)
libdvbpsi.so.7()(64bit)
Updated By: libdvbpsi-1.3.0-3.el7.x86_64 (epel)
~libdvbpsi.so.10()(64bit)
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

It seems the VLC application @nux-desktop needs package libdvbpsi-0.2.2-3.el7.nux.x86_64 but EPEL has updated that package to libdvbpsi-1.3.0-3.el7.x86_64.

Besides using --skip-broken and essentially ignoring this error, does VLC need to be updated to fix this problem?

My OS is CentOS Linux release 7.3.1611 (Core)
My kernel is: 3.10.0-514.6.1.el7.x86_64

Thanks.
Re: vlc-core and libdvbpsi.so.7 dependency [message #3770 is a reply to message #3769] Thu, 26 January 2017 11:11 Go to previous messageGo to next message
nux is currently offline  nux
Messages: 1659
Registered: January 2012
Senior Member
Administrator

You seem to be running an old verasion of VLC, this is what I have:

$rpm -qa|egrep 'vlc|dvbpsi'
vlc-core-2.2.2-6.el7.nux.x86_64
vlc-2.2.2-6.el7.nux.x86_64
libdvbpsi-1.3.0-3.el7.x86_64
vlc-extras-2.2.2-6.el7.nux.x86_64


Can you try a "yum clean all; yum install vlc" and see what happens?
Re: vlc-core and libdvbpsi.so.7 dependency [message #3771 is a reply to message #3769] Thu, 26 January 2017 11:26 Go to previous messageGo to next message
nux is currently offline  nux
Messages: 1659
Registered: January 2012
Senior Member
Administrator

Hm, hold on, I do see some issues with live555, let me attempt a rebuild.
Re: vlc-core and libdvbpsi.so.7 dependency [message #3772 is a reply to message #3769] Thu, 26 January 2017 11:53 Go to previous messageGo to next message
nux is currently offline  nux
Messages: 1659
Registered: January 2012
Senior Member
Administrator

Actually false alarm, all seems fine.
Do try what I suggested earlier and clean up yum then retry.
Re: vlc-core and libdvbpsi.so.7 dependency [message #3773 is a reply to message #3772] Thu, 26 January 2017 12:36 Go to previous message
cjatl404 is currently offline  cjatl404
Messages: 2
Registered: January 2017
Junior Member
You got me fixed, thanks! It was an old version and now I'm updated. Appreciate your help.
Previous Topic: ffmpeg2theora on EL7
Next Topic: Some Strange Package Errors While Installing VLC
Goto Forum:
  


Current Time: Sun Aug 25 15:26:56 BST 2019

Total time taken to generate the page: 0.00912 seconds