Nux!


Home » Repos » Report a problem or request a package » qtwebkit version conflict (EL7)
qtwebkit version conflict (EL7) [message #3119] Wed, 01 April 2015 19:03 Go to next message
constantin is currently offline  constantin
Messages: 82
Registered: July 2014
Location: Ukraine
Member
Hi, Nux!
Please, resolve version mismatch conflict of x86_54 (2.3.3-3.el7 in EPEL) and i686 (2.3.4-3.el7 in nux-dextop) builds of qtwebkit. Either rebuild newer x86_64 rpm, or remove new i686 from dextop repo. Thanks Smile

P.S. i686 package is required by some builds of skype.

[Updated on: Wed, 01 April 2015 19:13]

Report message to a moderator

Re: qtwebkit version conflict (EL7) [message #3127 is a reply to message #3119] Thu, 02 April 2015 13:11 Go to previous messageGo to next message
nux is currently offline  nux
Messages: 1659
Registered: January 2012
Senior Member
Administrator

Hello,

Yes, I was a bit trigger-happy about this one, sorry.
EPEL have the same version in epel-testing, so I moved mine as well in nux-dextop-testing and will wait for them.
Re: qtwebkit version conflict (EL7) [message #3133 is a reply to message #3127] Fri, 03 April 2015 14:29 Go to previous messageGo to next message
Jason is currently offline  Jason
Messages: 3
Registered: January 2015
Junior Member
Hey Nux!

I have this same issue too. I tried to update this morning and ran into this qtwebkit-2.3.4-3.el7.i686 problem. (I have qtwebkit 2.3.3 x86_64 installed from EPEL--required by owncloud-client.)

BTW, thanks for all your hard work on this awesome repo! =)
Re: qtwebkit version conflict (EL7) [message #3134 is a reply to message #3119] Sat, 04 April 2015 01:50 Go to previous messageGo to next message
nux is currently offline  nux
Messages: 1659
Registered: January 2012
Senior Member
Administrator

"yum clean all" and try again Smile
Re: qtwebkit version conflict (EL7) [message #3147 is a reply to message #3119] Tue, 07 April 2015 10:40 Go to previous messageGo to next message
flaminmoe is currently offline  flaminmoe
Messages: 3
Registered: April 2015
Junior Member
Hi Nux,

ht tp://li.nux.ro/download/nux/dextop/el7Workstation/x86_64/

still lists qtwebkit-2.3.4-3.el7.i686.rpm

and after a "yum clean all" it still wants to install. So the conflict is still there.

Best,
Mo
Re: qtwebkit version conflict (EL7) [message #3148 is a reply to message #3119] Wed, 08 April 2015 08:26 Go to previous messageGo to next message
nux is currently offline  nux
Messages: 1659
Registered: January 2012
Senior Member
Administrator

Hi,

That can't be, can you please paste the output of the yum operation?

Re: qtwebkit version conflict (EL7) [message #3149 is a reply to message #3119] Wed, 08 April 2015 09:40 Go to previous messageGo to next message
flaminmoe is currently offline  flaminmoe
Messages: 3
Registered: April 2015
Junior Member
Hi Nux,

please finde attached the yum output.

Best,
Mo
Re: qtwebkit version conflict (EL7) [message #3150 is a reply to message #3119] Wed, 08 April 2015 22:47 Go to previous messageGo to next message
nux is currently offline  nux
Messages: 1659
Registered: January 2012
Senior Member
Administrator

You use "--enablerepo=*" which enables nux-dextop-testing ... which should not be used unless you know what you're doing..
Re: qtwebkit version conflict (EL7) [message #3151 is a reply to message #3150] Thu, 09 April 2015 11:21 Go to previous messageGo to next message
flaminmoe is currently offline  flaminmoe
Messages: 3
Registered: April 2015
Junior Member
I used the enablerpo only on the yum clean all

on the yum check-update there is only a --noplugins (to disable yum-closest-mirror, yum-priorities, etc...)

The package comes with nux testing disabled.

Best,
Mo
Re: qtwebkit version conflict (EL7) [message #3152 is a reply to message #3119] Thu, 09 April 2015 14:41 Go to previous messageGo to next message
Jason is currently offline  Jason
Messages: 3
Registered: January 2015
Junior Member
Nux,

FYI, I still have this issue too. I did a yum clean all and yum check-updates just now (see attached). I installed the nux-dextop-release package according to the instructions here:

http://li.nux.ro/repos.html

The repo file it installs has been unmodified by me (nux-dextop = enabled, nux-dextop-testing = disabled). My baseurl's are:

http://li.nux.ro/download/nux/dextop/el7/$basearch/
http://mirror.li.nux.ro/li.nux.ro/nux/dextop/el7/$basearch/

...which resolves to these offending files:

http://li.nux.ro/download/nux/dextop/el7/x86_64/qtwebkit-2.3 .4-3.el7.i686.rpm
http://mirrors.coreix.net/li.nux.ro/nux/dextop/el7/x86_64/qt webkit-2.3.4-3.el7.i686.rpm

Hope this helps!
Re: qtwebkit version conflict (EL7) [message #3156 is a reply to message #3119] Sat, 11 April 2015 00:02 Go to previous messageGo to next message
nux is currently offline  nux
Messages: 1659
Registered: January 2012
Senior Member
Administrator

Yes, I see EPEL moved their package from epel-testing to the main repo.
I'll move my 32bit qtwebkit shortly to match their version. Hopefully this will fix your issues.
Re: qtwebkit version conflict (EL7) [message #3159 is a reply to message #3156] Mon, 13 April 2015 22:04 Go to previous message
Jason is currently offline  Jason
Messages: 3
Registered: January 2015
Junior Member
Indeed! This fixes my issue. Thanks Nux!
Previous Topic: gscan2pdf
Next Topic: Package request for EL7
Goto Forum:
  


Current Time: Sun Jul 21 17:49:02 BST 2019

Total time taken to generate the page: 0.44220 seconds