Nux!


Home » Repos » Report a problem or request a package » Kdenlive 0.9.10 segfaults (Segmentation fult when trying to run kdenlive)
Kdenlive 0.9.10 segfaults [message #3749] Fri, 18 November 2016 08:07 Go to next message
giulix is currently offline  giulix
Messages: 10
Registered: June 2016
Junior Member
Ola,

kdenlive 0.9.10 segfaults when starting the program. Isn't the fact that CentOS 7 ships with kdelibs-devel 4.14 but with kde-runtime 4.10 going to be a problem? I could not install the recompiled kdenlive source from your repo because of this. Please, let me know if you need any additional info.

Thanks.

[Updated on: Fri, 18 November 2016 09:18]

Report message to a moderator

Re: Kdenlive 0.9.10 segfaults [message #3750 is a reply to message #3749] Fri, 18 November 2016 10:44 Go to previous messageGo to next message
nux is currently offline  nux
Messages: 1659
Registered: January 2012
Senior Member
Administrator

Hi,

No idea why that happens alas.. If you have any pointers, happy to try and fix the package.
Re: Kdenlive 0.9.10 segfaults [message #3751 is a reply to message #3750] Mon, 21 November 2016 07:51 Go to previous messageGo to next message
giulix is currently offline  giulix
Messages: 10
Registered: June 2016
Junior Member
I say, let's wait for 7.3 to kick in and then I'll check it again.

Thanks for your support so far...
Re: Kdenlive 0.9.10 segfaults [message #3757 is a reply to message #3751] Tue, 13 December 2016 13:29 Go to previous messageGo to next message
giulix is currently offline  giulix
Messages: 10
Registered: June 2016
Junior Member
Ok, so... It's still broken in 7.3. The odd thing is that if I download the source RPM from your repo, kdenlive-0.9.10-1, and try to build it, I immediately encounter an error because of a BuildRequire kdelibs4-devel. If I change this to kdelibs-devel, it builds fine, but when I try to reinstall I get a dependency error:
# yum install  kdenlive-0.9.10-1.el7.centos.x86_64.rpm
Loaded plugins: fastestmirror, langpacks, priorities
Examining kdenlive-0.9.10-1.el7.centos.x86_64.rpm: kdenlive-0.9.10-1.el7.centos.x86_64
Marking kdenlive-0.9.10-1.el7.centos.x86_64.rpm to be installed
Resolving Dependencies
--> Running transaction check
---> Package kdenlive.x86_64 0:0.9.10-1.el7.centos will be installed
--> Processing Dependency: kde-runtime >= 4.14.8 for package: kdenlive-0.9.10-1.el7.centos.x86_64
Loading mirror speeds from cached hostfile
 * base: mirror.crazynetwork.it
 * elrepo: ftp.cc.uoc.gr
 * epel: ftp.cc.uoc.gr
 * extras: mirror.crazynetwork.it
 * nux-dextop: li.nux.ro
 * updates: mirror.crazynetwork.it
--> Finished Dependency Resolution
Error: Package: kdenlive-0.9.10-1.el7.centos.x86_64 (/kdenlive-0.9.10-1.el7.centos.x86_64)
           Requires: kde-runtime >= 4.14.8
           Installed: kde-runtime-4.10.5-8.el7.x86_64 (@base)
               kde-runtime = 4.10.5-8.el7
 You could try using --skip-broken to work around the problem
** Found 4 pre-existing rpmdb problem(s), 'yum check' output follows:
ipa-client-4.4.0-14.el7.centos.x86_64 has installed conflicts freeipa-client: ipa-client-4.4.0-14.el7.centos.x86_64
ipa-client-common-4.4.0-14.el7.centos.noarch has installed conflicts freeipa-client-common: ipa-client-common-4.4.0-14.el7.centos.noarch
ipa-common-4.4.0-14.el7.centos.noarch has installed conflicts freeipa-common: ipa-common-4.4.0-14.el7.centos.noarch
ipa-python-compat-4.4.0-14.el7.centos.noarch has installed conflicts freeipa-python-compat: ipa-python-compat-4.4.0-14.el7.centos.noarch

It looks like the kde-runtime shipped with C7 is not compatible with this package. Any ideas?

[Updated on: Tue, 13 December 2016 13:30]

Report message to a moderator

Re: Kdenlive 0.9.10 segfaults [message #3758 is a reply to message #3749] Tue, 13 December 2016 13:40 Go to previous messageGo to next message
giulix is currently offline  giulix
Messages: 10
Registered: June 2016
Junior Member
It still segfaults in 7.3. The weird thing is that the source in your repo, kdenlive-0.9.10-1, BuildRequires kdelibs4-devel, which is not available. If I change it to kdelibs-devel, the package builds ok, but when I try to install, I get:
# yum install  kdenlive-0.9.10-1.el7.centos.x86_64.rpm
Loaded plugins: fastestmirror, langpacks, priorities
Examining kdenlive-0.9.10-1.el7.centos.x86_64.rpm: kdenlive-0.9.10-1.el7.centos.x86_64
Marking kdenlive-0.9.10-1.el7.centos.x86_64.rpm to be installed
Resolving Dependencies
--> Running transaction check
---> Package kdenlive.x86_64 0:0.9.10-1.el7.centos will be installed
--> Processing Dependency: kde-runtime >= 4.14.8 for package: kdenlive-0.9.10-1.el7.centos.x86_64
Loading mirror speeds from cached hostfile
 * base: mirror.crazynetwork.it
 * elrepo: ftp.cc.uoc.gr
 * epel: ftp.cc.uoc.gr
 * extras: mirror.crazynetwork.it
 * nux-dextop: li.nux.ro
 * updates: mirror.crazynetwork.it
--> Finished Dependency Resolution
Error: Package: kdenlive-0.9.10-1.el7.centos.x86_64 (/kdenlive-0.9.10-1.el7.centos.x86_64)
           Requires: kde-runtime >= 4.14.8
           Installed: kde-runtime-4.10.5-8.el7.x86_64 (@base)
               kde-runtime = 4.10.5-8.el7
 You could try using --skip-broken to work around the problem
** Found 4 pre-existing rpmdb problem(s), 'yum check' output follows:
ipa-client-4.4.0-14.el7.centos.x86_64 has installed conflicts freeipa-client: ipa-client-4.4.0-14.el7.centos.x86_64
ipa-client-common-4.4.0-14.el7.centos.noarch has installed conflicts freeipa-client-common: ipa-client-common-4.4.0-14.el7.centos.noarch
ipa-common-4.4.0-14.el7.centos.noarch has installed conflicts freeipa-common: ipa-common-4.4.0-14.el7.centos.noarch
ipa-python-compat-4.4.0-14.el7.centos.noarch has installed conflicts freeipa-python-compat: ipa-python-compat-4.4.0-14.el7.centos.noarch

Any ideas?

P.S. Sorry about double posting. Feel free to delete one or the other... I don't think I can.

[Updated on: Tue, 13 December 2016 18:58]

Report message to a moderator

Re: Kdenlive 0.9.10 segfaults [message #3759 is a reply to message #3749] Wed, 14 December 2016 10:37 Go to previous messageGo to next message
nux is currently offline  nux
Messages: 1659
Registered: January 2012
Senior Member
Administrator

Hello,

# yum provides kdelibs4-devel
.
.
.
6:kdelibs-devel-4.14.8-5.el7_2.i686 : Header files for compiling KDE 4 applications
Repo        : base
Matched from:
Provides    : kdelibs4-devel = 4.14.8-5.el7_2



6:kdelibs-devel-4.14.8-5.el7_2.x86_64 : Header files for compiling KDE 4 applications
Repo        : base
Matched from:
Provides    : kdelibs4-devel = 4.14.8-5.el7_2




Re: Kdenlive 0.9.10 segfaults [message #3760 is a reply to message #3749] Wed, 14 December 2016 11:09 Go to previous messageGo to next message
nux is currently offline  nux
Messages: 1659
Registered: January 2012
Senior Member
Administrator

Have you tried their AppImage?

http://download.kde.org/unstable/kdenlive/16.12/linux/Kdenli ve-16.12-rc-x86_64.AppImage

Just download, chmod +x and then ./ it.
Re: Kdenlive 0.9.10 segfaults [message #3761 is a reply to message #3749] Wed, 14 December 2016 11:25 Go to previous messageGo to next message
nux is currently offline  nux
Messages: 1659
Registered: January 2012
Senior Member
Administrator

Also, I think the problem may come from the fact CentOS base carries a mix of 4.10 and 4.14 KDE bits ... (kdelibs 4.14.8, but kde-runtime 4.10)

Re: Kdenlive 0.9.10 segfaults [message #3762 is a reply to message #3749] Thu, 15 December 2016 09:00 Go to previous messageGo to next message
giulix is currently offline  giulix
Messages: 10
Registered: June 2016
Junior Member
Hi, actually I am just relaying information from someone at CentOS forum. I had never used kdenlive before myself.

Thanks, anyway.

[Updated on: Thu, 15 December 2016 09:02]

Report message to a moderator

Re: Kdenlive 0.9.10 segfaults [message #3763 is a reply to message #3749] Thu, 15 December 2016 13:54 Go to previous message
nux is currently offline  nux
Messages: 1659
Registered: January 2012
Senior Member
Administrator

Thanks, I replied there as well.
Previous Topic: xine problem
Next Topic: pdftk pdfchain ? how to encrypt/un-encrypte pdfs?
Goto Forum:
  


Current Time: Fri Sep 20 06:10:20 BST 2019

Total time taken to generate the page: 0.01418 seconds