Nux!


Home » Stella » Report a problem or request a feature » Google Chrome - Something went wrong when opening your profile
Google Chrome - Something went wrong when opening your profile [message #3829] Fri, 05 May 2017 11:25 Go to next message
palacs is currently offline  palacs
Messages: 4
Registered: May 2017
Location: Hungary
Junior Member
I installed chrome-deps-stable from nux repos to mx CentOS 6 box, then installed google-chrome-stable from official repos of Google. All succeeded.

The problem is when I close Chrome, the application stays in the background and will never exit. Also, there is a defunct chrome process.

test      3321  2.2  1.1 878168 94912 ?        SLsl 12:00   0:13 /opt/google/chrome/chrome    
test      3327  0.0  0.0   6232   600 ?        S    12:00   0:00 /opt/google/chrome/chrome-sandbox /opt/google/chrome/chrome --type=zygote --enable-crash-reporter=5696d79a-7598-4771-8e19-6d45284e4cc8,
test      3328  0.0  0.3 417624 26164 ?        S    12:00   0:00 /opt/google/chrome/chrome --type=zygote --enable-crash-reporter=5696d79a-7598-4771-8e19-6d45284e4cc8,
test      3331  0.0  0.1 417624  8252 ?        S    12:00   0:00 /opt/google/chrome/chrome --type=zygote --enable-crash-reporter=5696d79a-7598-4771-8e19-6d45284e4cc8,
test      3388  0.9  0.0      0     0 ?        Z    12:00   0:05 [chrome] <defunct>

Next time I launch Chrome (old sandbox, zygote and defunct processes still running) it will display the following error.

index.php?t=getfile&id=275&private=0
I mostly use it under Xfce.

Anyone experienced this behavior?
Re: Google Chrome - Something went wrong when opening your profile [message #3830 is a reply to message #3829] Fri, 05 May 2017 16:39 Go to previous messageGo to next message
palacs is currently offline  palacs
Messages: 4
Registered: May 2017
Location: Hungary
Junior Member
Related (or same) issue: https://bugs.chromium.org/p/chromium/issues/detail?id=86948
Re: Google Chrome - Something went wrong when opening your profile [message #3831 is a reply to message #3829] Tue, 09 May 2017 08:12 Go to previous messageGo to next message
nux is currently offline  nux
Messages: 1522
Registered: January 2012
Senior Member
Administrator

Hi,

Yes, this happens to me too. Fortunately Chrome is not my main browser, so I am not really affected by this.
Google has declared EL6 platform dead for Chrome, so it's a wonder it still works at all.

As a workaround you could create a custom launcher that cleans up processes and invoke that from your toolbar Chrome shortcut, e.g.

#!/bin/bash

kill -9 $(ps aux|grep google|grep chrome|awk '{print $2}')
sleep 1
/usr/bin/google-chrome-stable "$@"

[Updated on: Tue, 09 May 2017 08:12]

Report message to a moderator

Re: Google Chrome - Something went wrong when opening your profile [message #3832 is a reply to message #3829] Tue, 09 May 2017 14:48 Go to previous message
palacs is currently offline  palacs
Messages: 4
Registered: May 2017
Location: Hungary
Junior Member
Yeah, I have created my own script as well but thanks for yours. Cool

Unfortunately, I feel this is only a temprary solution and Chrome can break any time at an upgrade and Google's idealist developers won't do anything about it.

How hard would it be to build the open-source Chromium natively for CentOS 6? So that it would use the glibc included in EL6 and might not need hacking around binary releases (like Google Chrome). Features that can't be supported on the CentOS 6 platform or are buggy could be turned off at build time.

Firefox is dropping GTK2 and does a switch to GTK3 (and it will be active in Firefox ESR in 2018). I wonder how Red Hat will deal with keeping it up and running. CentOS 6 doesn't have GTK3 (fortunately).

[Updated on: Tue, 09 May 2017 15:00]

Report message to a moderator

Previous Topic: Deliver skypeforlinux.x86_64 instead of skype.i586
Goto Forum:
  


Current Time: Tue May 23 23:31:29 BST 2017

Total time taken to generate the page: 0.00620 seconds