Nux!


Home » Stella » Report a problem or request a feature » Audacious dependency issues between Nux and EPEL repos
Audacious dependency issues between Nux and EPEL repos [message #3872] Wed, 19 July 2017 18:37 Go to next message
mullah is currently offline  mullah
Messages: 4
Registered: July 2017
Junior Member
I am having dependency issues while updating, associated to audacious and related packages, on both CentOS 7 and RHEL. I am using only the EPEL and Nux repositories, other than the standard ones.

Loaded plugins: langpacks, product-id, search-disabled-repos, subscription-
              : manager
Resolving Dependencies
--> Running transaction check
---> Package audacious.x86_64 0:3.5.1-1.el7.nux will be updated
---> Package audacious.x86_64 0:3.8.2-2.el7 will be an update
---> Package audacious-libs.x86_64 0:3.5.1-1.el7.nux will be updated
--> Processing Dependency: libaudcore.so.2()(64bit) for package: audacious-plugins-freeworld-mms-3.5-2.el7.nux.x86_64
--> Processing Dependency: libaudcore.so.2()(64bit) for package: audacious-plugins-freeworld-ffaudio-3.5-2.el7.nux.x86_64
--> Processing Dependency: libaudcore.so.2()(64bit) for package: audacious-plugins-freeworld-aac-3.5-2.el7.nux.x86_64
--> Processing Dependency: libaudgui.so.2()(64bit) for package: audacious-plugins-freeworld-mms-3.5-2.el7.nux.x86_64
--> Processing Dependency: libaudgui.so.2()(64bit) for package: audacious-plugins-freeworld-ffaudio-3.5-2.el7.nux.x86_64
--> Processing Dependency: libaudgui.so.2()(64bit) for package: audacious-plugins-freeworld-aac-3.5-2.el7.nux.x86_64
--> Processing Dependency: libaudtag.so.1()(64bit) for package: audacious-plugins-freeworld-ffaudio-3.5-2.el7.nux.x86_64
---> Package audacious-libs.x86_64 0:3.8.2-2.el7 will be an update
---> Package audacious-plugins.x86_64 0:3.5.2-1.el7.nux will be updated
---> Package audacious-plugins.x86_64 0:3.8.2-3.el7 will be obsoleting
--> Processing Dependency: libQt5Multimedia.so.5(Qt_5)(64bit) for package: audacious-plugins-3.8.2-3.el7.x86_64
--> Processing Dependency: libQt5Multimedia.so.5()(64bit) for package: audacious-plugins-3.8.2-3.el7.x86_64
---> Package audacious-plugins-freeworld-mp3.x86_64 0:3.5-2.el7.nux will be obsoleted
--> Processing Dependency: audacious-plugins-freeworld-mp3 = 3.5-2.el7.nux for package: audacious-plugins-freeworld-3.5-2.el7.nux.x86_64
---> Package lame-libs.x86_64 0:3.99.5-2.el7 will be updated
---> Package lame-libs.x86_64 0:3.99.5-8.el7 will be an update
---> Package libcue.x86_64 0:1.3.0-6.el7.nux will be updated
---> Package libcue.x86_64 0:2.1.0-2.el7 will be an update
---> Package libmpg123.x86_64 0:1.15.1-1.el7.nux will be obsoleted
---> Package mpg123-libs.x86_64 0:1.23.8-5.el7 will be obsoleting
--> Running transaction check
---> Package audacious-libs.x86_64 0:3.5.1-1.el7.nux will be updated
--> Processing Dependency: libaudcore.so.2()(64bit) for package: audacious-plugins-freeworld-mms-3.5-2.el7.nux.x86_64
--> Processing Dependency: libaudcore.so.2()(64bit) for package: audacious-plugins-freeworld-ffaudio-3.5-2.el7.nux.x86_64
--> Processing Dependency: libaudcore.so.2()(64bit) for package: audacious-plugins-freeworld-aac-3.5-2.el7.nux.x86_64
--> Processing Dependency: libaudgui.so.2()(64bit) for package: audacious-plugins-freeworld-mms-3.5-2.el7.nux.x86_64
--> Processing Dependency: libaudgui.so.2()(64bit) for package: audacious-plugins-freeworld-ffaudio-3.5-2.el7.nux.x86_64
--> Processing Dependency: libaudgui.so.2()(64bit) for package: audacious-plugins-freeworld-aac-3.5-2.el7.nux.x86_64
--> Processing Dependency: libaudtag.so.1()(64bit) for package: audacious-plugins-freeworld-ffaudio-3.5-2.el7.nux.x86_64
---> Package audacious-plugins-freeworld-mp3.x86_64 0:3.5-2.el7.nux will be obsoleted
--> Processing Dependency: audacious-plugins-freeworld-mp3 = 3.5-2.el7.nux for package: audacious-plugins-freeworld-3.5-2.el7.nux.x86_64
---> Package qt5-qtmultimedia.x86_64 0:5.6.1-10.el7 will be installed
--> Finished Dependency Resolution
--> Finding unneeded leftover dependencies
Found and removing 0 unneeded dependencies
Error: Package: audacious-plugins-freeworld-aac-3.5-2.el7.nux.x86_64 (@nux-dextop)
           Requires: libaudcore.so.2()(64bit)
           Removing: audacious-libs-3.5.1-1.el7.nux.x86_64 (@nux-dextop)
               libaudcore.so.2()(64bit)
           Updated By: audacious-libs-3.8.2-2.el7.x86_64 (epel)
              ~libaudcore.so.4()(64bit)
Error: Package: audacious-plugins-freeworld-aac-3.5-2.el7.nux.x86_64 (@nux-dextop)
           Requires: libaudgui.so.2()(64bit)
           Removing: audacious-libs-3.5.1-1.el7.nux.x86_64 (@nux-dextop)
               libaudgui.so.2()(64bit)
           Updated By: audacious-libs-3.8.2-2.el7.x86_64 (epel)
              ~libaudgui.so.4()(64bit)
Error: Package: audacious-plugins-freeworld-ffaudio-3.5-2.el7.nux.x86_64 (@nux-dextop)
           Requires: libaudcore.so.2()(64bit)
           Removing: audacious-libs-3.5.1-1.el7.nux.x86_64 (@nux-dextop)
               libaudcore.so.2()(64bit)
           Updated By: audacious-libs-3.8.2-2.el7.x86_64 (epel)
              ~libaudcore.so.4()(64bit)
Error: Package: audacious-plugins-freeworld-mms-3.5-2.el7.nux.x86_64 (@nux-dextop)
           Requires: libaudgui.so.2()(64bit)
           Removing: audacious-libs-3.5.1-1.el7.nux.x86_64 (@nux-dextop)
               libaudgui.so.2()(64bit)
           Updated By: audacious-libs-3.8.2-2.el7.x86_64 (epel)
              ~libaudgui.so.4()(64bit)
Error: Package: audacious-plugins-freeworld-3.5-2.el7.nux.x86_64 (@nux-dextop)
           Requires: audacious-plugins-freeworld-mp3 = 3.5-2.el7.nux
           Removing: audacious-plugins-freeworld-mp3-3.5-2.el7.nux.x86_64 (@nux-dextop)
               audacious-plugins-freeworld-mp3 = 3.5-2.el7.nux
           Obsoleted By: audacious-plugins-3.8.2-3.el7.x86_64 (epel)
               audacious-plugins-freeworld-mp3 = 3.8.2-3.el7
Error: Package: audacious-plugins-freeworld-mms-3.5-2.el7.nux.x86_64 (@nux-dextop)
           Requires: libaudcore.so.2()(64bit)
           Removing: audacious-libs-3.5.1-1.el7.nux.x86_64 (@nux-dextop)
               libaudcore.so.2()(64bit)
           Updated By: audacious-libs-3.8.2-2.el7.x86_64 (epel)
              ~libaudcore.so.4()(64bit)
Error: Package: audacious-plugins-freeworld-ffaudio-3.5-2.el7.nux.x86_64 (@nux-dextop)
           Requires: libaudgui.so.2()(64bit)
           Removing: audacious-libs-3.5.1-1.el7.nux.x86_64 (@nux-dextop)
               libaudgui.so.2()(64bit)
           Updated By: audacious-libs-3.8.2-2.el7.x86_64 (epel)
              ~libaudgui.so.4()(64bit)
Error: Package: audacious-plugins-freeworld-ffaudio-3.5-2.el7.nux.x86_64 (@nux-dextop)
           Requires: libaudtag.so.1()(64bit)
           Removing: audacious-libs-3.5.1-1.el7.nux.x86_64 (@nux-dextop)
               libaudtag.so.1()(64bit)
           Updated By: audacious-libs-3.8.2-2.el7.x86_64 (epel)
              ~libaudtag.so.3()(64bit)
**********************************************************************
yum can be configured to try to resolve such errors by temporarily enabling
disabled repos and searching for missing dependencies.
To enable this functionality please set 'notify_only=0' in /etc/yum/pluginconf.d/search-disabled-repos.conf
**********************************************************************

Error: Package: audacious-plugins-freeworld-aac-3.5-2.el7.nux.x86_64 (@nux-dextop)
           Requires: libaudcore.so.2()(64bit)
           Removing: audacious-libs-3.5.1-1.el7.nux.x86_64 (@nux-dextop)
               libaudcore.so.2()(64bit)
           Updated By: audacious-libs-3.8.2-2.el7.x86_64 (epel)
              ~libaudcore.so.4()(64bit)
Error: Package: audacious-plugins-freeworld-aac-3.5-2.el7.nux.x86_64 (@nux-dextop)
           Requires: libaudgui.so.2()(64bit)
           Removing: audacious-libs-3.5.1-1.el7.nux.x86_64 (@nux-dextop)
               libaudgui.so.2()(64bit)
           Updated By: audacious-libs-3.8.2-2.el7.x86_64 (epel)
              ~libaudgui.so.4()(64bit)
Error: Package: audacious-plugins-freeworld-ffaudio-3.5-2.el7.nux.x86_64 (@nux-dextop)
           Requires: libaudcore.so.2()(64bit)
           Removing: audacious-libs-3.5.1-1.el7.nux.x86_64 (@nux-dextop)
               libaudcore.so.2()(64bit)
           Updated By: audacious-libs-3.8.2-2.el7.x86_64 (epel)
              ~libaudcore.so.4()(64bit)
Error: Package: audacious-plugins-freeworld-mms-3.5-2.el7.nux.x86_64 (@nux-dextop)
           Requires: libaudgui.so.2()(64bit)
           Removing: audacious-libs-3.5.1-1.el7.nux.x86_64 (@nux-dextop)
               libaudgui.so.2()(64bit)
           Updated By: audacious-libs-3.8.2-2.el7.x86_64 (epel)
              ~libaudgui.so.4()(64bit)
Error: Package: audacious-plugins-freeworld-3.5-2.el7.nux.x86_64 (@nux-dextop)
           Requires: audacious-plugins-freeworld-mp3 = 3.5-2.el7.nux
           Removing: audacious-plugins-freeworld-mp3-3.5-2.el7.nux.x86_64 (@nux-dextop)
               audacious-plugins-freeworld-mp3 = 3.5-2.el7.nux
           Obsoleted By: audacious-plugins-3.8.2-3.el7.x86_64 (epel)
               audacious-plugins-freeworld-mp3 = 3.8.2-3.el7
Error: Package: audacious-plugins-freeworld-mms-3.5-2.el7.nux.x86_64 (@nux-dextop)
           Requires: libaudcore.so.2()(64bit)
           Removing: audacious-libs-3.5.1-1.el7.nux.x86_64 (@nux-dextop)
               libaudcore.so.2()(64bit)
           Updated By: audacious-libs-3.8.2-2.el7.x86_64 (epel)
              ~libaudcore.so.4()(64bit)
Error: Package: audacious-plugins-freeworld-ffaudio-3.5-2.el7.nux.x86_64 (@nux-dextop)
           Requires: libaudgui.so.2()(64bit)
           Removing: audacious-libs-3.5.1-1.el7.nux.x86_64 (@nux-dextop)
               libaudgui.so.2()(64bit)
           Updated By: audacious-libs-3.8.2-2.el7.x86_64 (epel)
              ~libaudgui.so.4()(64bit)
Error: Package: audacious-plugins-freeworld-ffaudio-3.5-2.el7.nux.x86_64 (@nux-dextop)
           Requires: libaudtag.so.1()(64bit)
           Removing: audacious-libs-3.5.1-1.el7.nux.x86_64 (@nux-dextop)
               libaudtag.so.1()(64bit)
           Updated By: audacious-libs-3.8.2-2.el7.x86_64 (epel)
              ~libaudtag.so.3()(64bit)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
Re: Audacious dependency issues between Nux and EPEL repos [message #3873 is a reply to message #3872] Thu, 20 July 2017 09:35 Go to previous messageGo to next message
nux is currently offline  nux
Messages: 1546
Registered: January 2012
Senior Member
Administrator

Hello,

Try to do a "yum clean all" and try again.
EPEL now can ship mp3 software as the patent expired so I have removed my packages.
Re: Audacious dependency issues between Nux and EPEL repos [message #3876 is a reply to message #3873] Fri, 21 July 2017 19:21 Go to previous messageGo to next message
mullah is currently offline  mullah
Messages: 4
Registered: July 2017
Junior Member
Thanks for the help, indeed the EPEL packages are providing support for mp3 now.

Simply doing a "yum clean all" followed by "yum update" wasn't enough to fix the dependency problems, I had to manually remove Nux packages by doing a "yum remove audacious-plugins-freeworld-*" before being able to update. Everything is working now.
Re: Audacious dependency issues between Nux and EPEL repos [message #3877 is a reply to message #3872] Mon, 24 July 2017 09:33 Go to previous message
nux is currently offline  nux
Messages: 1546
Registered: January 2012
Senior Member
Administrator

Thanks for the feedback, I have issued an update audacious-plugins-freeworld package from Rpmfusion which should make all this smoother.

Let me know if you encounter any further issues.
Previous Topic: kodi-pvr-iptvsimple-14.0 - incompatible API version
Next Topic:
Goto Forum:
  


Current Time: Thu Aug 17 12:45:24 BST 2017

Total time taken to generate the page: 0.00741 seconds