Nux!


Home » Stella » General chat » Installing a virtual machine on Stella
Installing a virtual machine on Stella [message #963] Wed, 13 February 2013 21:14 Go to next message
MrNice is currently offline  MrNice
Messages: 108
Registered: December 2012
Location: Ireland
Senior Member
Hi,

I'd like to install a virtual machine to run other OS, linux and M$ for test.
I don't know the best choice but I have read VirtualBox has bug.

Someone could help me for:
- A good choice
- Where to find the setup file
- What are the steps for install or a link to an "how to"

Thanks
Re: Installing a virtual machine on Stella [message #966 is a reply to message #963] Wed, 13 February 2013 22:29 Go to previous messageGo to next message
nux is currently offline  nux
Messages: 1652
Registered: January 2012
Senior Member
Administrator

If your CPU[1] can do virtualisation you can use KVM from virt-manager:
yum install virt-manager libvirt qemu-kvm
service libvirtd start; chkconfig libvirtd on


Then start Virt-manager, it's quite intuitive, behaves similarly to virtualbox.

[1] - if this returns a result, you're in luck: egrep --color 'vmx|svm' /proc/cpuinfo
Re: Installing a virtual machine on Stella [message #968 is a reply to message #963] Fri, 15 February 2013 11:28 Go to previous messageGo to next message
MrNice is currently offline  MrNice
Messages: 108
Registered: December 2012
Location: Ireland
Senior Member
Thanks for the tips.
I installed VMM with Ubuntu 11.04 as guest. Running.

However I succeeded to install an USB key but I can't install my Dazzle DVC100 USB device.
In the Host guest not running
As this is a video device, I can see it with
ls /dev/video*
/dev/video0

lsusb
Bus 002 Device 013: ID 2304:021a Pinnacle Systems, Inc. Dazzle DVC100 Audio Device

In the guest
I can see the device in the VMM "Detail" configuration
Device: 002:013 Pinnacle Systems GmbH DVC100

but in a terminal
lsusb
Bus 001 Device 003: ID 0000:0000

ls /dev/video*
ls: cannot access /dev/video*: no such file or directory


and the device is still visible in the host
I tried to start, connect at different time, nothing better.

How can I activate this device in the guest machine?


Re: Installing a virtual machine on Stella [message #969 is a reply to message #963] Fri, 15 February 2013 23:24 Go to previous messageGo to next message
nux is currently offline  nux
Messages: 1652
Registered: January 2012
Senior Member
Administrator

No idea and I'm hard pressed with time for researching it, this may belong better on centos-virt@centos.org or some other virt/qemu specific list.
Re: Installing a virtual machine on Stella [message #977 is a reply to message #963] Mon, 18 February 2013 03:33 Go to previous messageGo to next message
jpisini is currently offline  jpisini
Messages: 20
Registered: February 2013
Junior Member
Not sure what bug you read abou but I have been using the latest VirtualBox for a while at home with no issues. It is free so only costs a little time to try it out. At work I use VMware which is hard to beat but isn't free.
Re: Installing a virtual machine on Stella [message #979 is a reply to message #977] Mon, 18 February 2013 10:58 Go to previous message
MrNice is currently offline  MrNice
Messages: 108
Registered: December 2012
Location: Ireland
Senior Member
I used to use VirtualBox in Ubuntu although I newer tried my Dazzle DVC100 with it.

I am puzzled to use it in Stella as it seems to not be working seamlessly.
https://forums.nux.ro/index.php?t=msg&th=160&start=0 &

For information:
I tried VMM with Debian guest and I got the same error.

Previous Topic: Happy to use Stella6.3
Next Topic: Ongoing Support for Stella Down the Road?
Goto Forum:
  


Current Time: Wed Mar 27 00:11:50 GMT 2019

Total time taken to generate the page: 0.01510 seconds