Nux!


Home » Stella » Report a problem or request a feature » transaction error updating gstreamer
transaction error updating gstreamer [message #1491] Tue, 08 October 2013 23:17 Go to next message
loopnode
Messages: 20
Registered: October 2012
Location: earth-based
Junior Member
Hi Nux!

When trying to update GStreamer I get a transaction error. Anyone else run into this? I'm finally mentioning it on the list, but the error began 2 or 3 months ago. As I've only used the repos suggested here, any idea what the cause is & best way to solve it?

Here's the message > > >

Error: Multilib version problems found. This often means that the root
cause is something else and multilib version checking is just
pointing out that there is a problem. Eg.:

1. You have an upgrade for gstreamer which is missing some
dependency that another package requires. Yum is trying to
solve this by installing an older version of gstreamer of the
different architecture. If you exclude the bad architecture
yum will tell you what the root cause is (which package
requires what). You can try redoing the upgrade with
--exclude gstreamer.otherarch ... this should give you an error
message showing the root cause of the problem.

2. You have multiple architectures of gstreamer installed, but
yum can only see an upgrade for one of those arcitectures.
If you don't want/need both architectures anymore then you
can remove the one with the missing update and everything
will work.

3. You have duplicate versions of gstreamer installed already.
You can use "yum check" to get yum show these errors.

...you can also use --setopt=protected_multilib=false to remove
this checking, however this is almost never the correct thing to
do as something else is very likely to go wrong (often causing
much more problems).

Protected multilib versions: gstreamer-0.10.34-1stella.x86_64 != gstreamer-0.10.29-1.el6.i686
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

-loopnode
Re: transaction error updating gstreamer [message #1492 is a reply to message #1491] Wed, 09 October 2013 12:39 Go to previous messageGo to next message
nux is currently offline  nux
Messages: 1659
Registered: January 2012
Senior Member
Administrator

Hi,

gstreamer-0.10.34-1stella.x86_64 is not part of Stella, it's made by Symbianflo, not sure how it got in your system.
The RPMs he built were for testing and overwrite Base packages, try to "yum downgrade gstreamer\*", see if that reverts to the old versions.

Re: transaction error updating gstreamer [message #1493 is a reply to message #1492] Wed, 09 October 2013 18:14 Go to previous messageGo to next message
symbianflo is currently offline  symbianflo
Messages: 176
Registered: January 2012
Location: italy
Senior Member

hi
it was a year ago and kind of cutting edge, at the time.... and won't overwrite the stella base , that's why you can not upgrade..you have 2 versions of gst installed
pick one , at your choice ( better listen to Nux..), and stick with it.

[Updated on: Wed, 09 October 2013 18:18]

Report message to a moderator

Re: transaction error updating gstreamer [message #1494 is a reply to message #1492] Wed, 09 October 2013 23:44 Go to previous messageGo to next message
loopnode
Messages: 20
Registered: October 2012
Location: earth-based
Junior Member
nux wrote on Wed, 09 October 2013 04:39
Hi,

gstreamer-0.10.34-1stella.x86_64 is not part of Stella, it's made by Symbianflo, not sure how it got in your system.
The RPMs he built were for testing and overwrite Base packages, try to "yum downgrade gstreamer\*", see if that reverts to the old versions.


Hmm, I can't recall exactly when or why I enabled Symbianflo's repo. But, "yum downgrade gstreamer\*" didn't work (I got the same "multilib version problems found."). I then tried to remove gstreamer-0.10.34-1stella.x86_64 & yum stated it was available but not installed. Then, I disabled symbianflo.repo & everything seems to be back to normal. I'm not sure that was the best way to go about it. It seems to have worked, but if I need to enable Symbianflo's repo in the future the problem could bite me again.

Is there a better way to go about it?

thanks for the help, Nux!
-loop
Re: transaction error updating gstreamer [message #1495 is a reply to message #1493] Wed, 09 October 2013 23:48 Go to previous messageGo to next message
loopnode
Messages: 20
Registered: October 2012
Location: earth-based
Junior Member
symbianflo wrote on Wed, 09 October 2013 10:14
hi
it was a year ago and kind of cutting edge, at the time.... and won't overwrite the stella base , that's why you can not upgrade..you have 2 versions of gst installed
pick one , at your choice ( better listen to Nux..), and stick with it.

Hi Symbianflo,

Thanks for the info. I hope I've resolved my problem (at least for the moment. Smile)

-loop
Re: transaction error updating gstreamer [message #1499 is a reply to message #1494] Thu, 10 October 2013 17:49 Go to previous message
symbianflo is currently offline  symbianflo
Messages: 176
Registered: January 2012
Location: italy
Senior Member

I don't think you'll need my repos to be active , it's enough to enable it when occur , or when you whant to install something from there.
Previous Topic: LVM : powerful but tough
Next Topic: YouTube Wont Play Properly
Goto Forum:
  


Current Time: Fri Sep 20 13:22:20 BST 2019

Total time taken to generate the page: 0.01207 seconds