Nux!


Home » Repos » Report a problem or request a package » motion-Gui,motion (video surveilance)
motion-Gui,motion [message #1511] Wed, 16 October 2013 17:48 Go to next message
kleo is currently offline  kleo
Messages: 92
Registered: February 2012
Member
I am very curios how this will work on Stella:

http://sourceforge.net/projects/motiongui/
http://sourceforge.net/projects/motion/

Thanks!
Re: motion-Gui,motion [message #1512 is a reply to message #1511] Wed, 16 October 2013 19:17 Go to previous messageGo to next message
nux is currently offline  nux
Messages: 1662
Registered: January 2012
Senior Member
Administrator

kleo,

I'll try to have a look at this by next week.

Re: motion-Gui,motion [message #1519 is a reply to message #1511] Mon, 21 October 2013 16:12 Go to previous messageGo to next message
nux is currently offline  nux
Messages: 1662
Registered: January 2012
Senior Member
Administrator

I've added both software to my repo, please give it a test and let me know if it works to your expectations.

Re: motion-Gui,motion [message #1546 is a reply to message #1519] Wed, 30 October 2013 16:25 Go to previous messageGo to next message
kleo is currently offline  kleo
Messages: 92
Registered: February 2012
Member
I tested motion-Gui with "Omega" webcam,bttv video surveilance card with single chip "CONEXANT FUSION 878A 25878-132",color CCD YR-300 camera attached to that card.


1.Insert diferent driver bttv options:

a) rmmod bttv
b) This time I tried different driver options:
modprobe bttv gbuffers=32 card=158 tuner=4 radio=0 coring=1 full_luma_range=1 chroma_agc=1 combfilter=1 autoload=0 triton1=0 vsfx=0
For choosing card number I was looking at https://www.kernel.org/doc/Documentation/video4linux/CARDLIS T.bttv
and for other options at http://xawdecode.sourceforge.net/aideUS/htmlpage/BTTV-param. htm

2.Add motion-Gui to panel:

a) whereis motion-Gui
motion-Gui: /usr/bin/motion-Gui
b)
index.php?t=getfile&id=103&private=0
3.Basic motion configuration:
a) I created two folders c1 and c2 on Desktop for saving images and *.avi files for two cameras without changing permissions,ownership ...
b)Pressing first "thread1" for camera1 and then "configure" button on motion-Gui I got window with configuration tabs for camera1.
At "Capture" tab I have changed width:640,height:480,framerate:25,auto_brightness:on.
At "Configure" tab I leaved default.
At "Name" tab I changed tartget_dir:/home/klemens/Desktop/c1
At "Detection" tab threshold:200 (to capture more movies),pre_capture:3,post_capture:3,minimum_motion_frames:1 0
At "ffmpeg" tab output_normal:off (this way I get only movies and avoid pictures),quality:75
At "http" tab webcam_port:8081,control port:8080
Other tabs I didn't look.

For camera2: first pressing "thread2" button then "Configure" button,target_dir:home/klemens/Desktop/c2,wewbcam_port:8083, control_port:8082-this must differ from camera1 other parameters can be the same.
I noticed that I have to press "stop" then "start" buttons for changes to be done at "thread1"(camera1) or "thread2"(camera2 in my case)
For configuration options I helped myself with http://www.lavrsen.dk/foswiki/bin/view/Motion/MotionGuide
index.php?t=getfile&id=104&private=0
index.php?t=getfile&id=105&private=0

3) start motion:
for camera1 I pressed "thread1" button then "start",for camera2 "thread2" then "start".

4) Live camera view:
a)gedit /home/klemens/Desktop/live.html
I edited at that file this:
<html>
<body bgcolor="#000000">
<a href="http://localhost.html"> <img src=http://localhost:8081/ border="0" width=49%></a>
<a href="http://localhost.html"> <img src=http://localhost:8083/ border="0" width=49%></a> <br>
</body>
</html>

b)firefox /home/klemens/Desktop/live.html

that gave me live streamings of both cameras.
index.php?t=getfile&id=106&private=0

c) Pressing "thread1" button then "Web Browser" button gave me camera1 live view at vlc media player,similiar I got for camera2
This only works if I have vlc installed

index.php?t=getfile&id=107&private=0

I have experimented with different parameters getting various results. It seems that is the only way.I didn't noticed any crashes.
When I press "Web Control" button nothing happens,I could not figure out why. I could not succeed to change parameters at "Settings" button.
At this moment I didn't take a test at "Command" tab options,"Sql" tab options,"Tracking" tab options,netcam_* options,video_pipe,motion_video_pipe.
Well, at my tests motion-Gui is doing the job!


[Updated on: Wed, 30 October 2013 16:34]

Report message to a moderator

Re: motion-Gui,motion [message #1547 is a reply to message #1511] Wed, 30 October 2013 17:40 Go to previous message
nux is currently offline  nux
Messages: 1662
Registered: January 2012
Senior Member
Administrator

Wow, thanks for the feedback! Glad it's working, even if partially.

Previous Topic: APE FLAC convert, split and tag
Next Topic: Package request
Goto Forum:
  


Current Time: Mon Dec 16 05:54:51 GMT 2019

Total time taken to generate the page: 0.03097 seconds