Nux!


Home » Repos » Report a problem or request a package » VLC 2.1.4 Decoder Errors (VLC 2.1.4 Decoder Errors)
VLC 2.1.4 Decoder Errors [message #1837] Fri, 11 July 2014 07:42 Go to next message
crxtasy12 is currently offline  crxtasy12
Messages: 5
Registered: July 2014
Junior Member
Hi,

I seem to be having some problems with the VLC package I installed from your repo. I have made sure the epel repository is enabled. I got VLC installed but when I play a video file I keep getting these errors. I'm not sure if it is due to installing Plex from Plex.tv or if there is a problem with the VLC package. I am using Centos 7 and I'm still getting used to it. Please let me know what I can do to help resolve this.

No suitable decoder module:

VLC does not support the audio or video format "mp4v". Unfortunately there is no way for you to fix this


No suitable decoder module:

VLC does not support the audio or video format "h264". Unfortunately there is no way for you to fix this.

Thanks,
Rey Cruz
Re: VLC 2.1.4 Decoder Errors [message #1840 is a reply to message #1837] Fri, 11 July 2014 10:03 Go to previous messageGo to next message
nux is currently offline  nux
Messages: 1662
Registered: January 2012
Senior Member
Administrator

Hello,

It must be something you done, VLC from my repo can play all the formats here out of the box:
http://www.bigbuckbunny.org/index.php/download/

I always use those as test/benchmark.
Re: VLC 2.1.4 Decoder Errors [message #1841 is a reply to message #1837] Fri, 11 July 2014 10:04 Go to previous messageGo to next message
nux is currently offline  nux
Messages: 1662
Registered: January 2012
Senior Member
Administrator

Can you copy/paste from your bash history what steps you have taken to install that plex software?
Re: VLC 2.1.4 Decoder Errors [message #1842 is a reply to message #1841] Fri, 11 July 2014 23:41 Go to previous messageGo to next message
crxtasy12 is currently offline  crxtasy12
Messages: 5
Registered: July 2014
Junior Member
I installed it the same way I installed it on fedora. Downloaded the rpm by clicking the download button their site. It prompts me to install and asks for admin password. It handles the rest. So you will not see anything in my bash history other than trying to get handbrake working however I appended it any way. Its the first thing I installed.

sudo rpm --import https://www.elrepo.org/RPM-GPG-KEY-elrepo.org
sudo rpm -Uvh http://www.elrepo.org/elrepo-release-7.0-2.el7.elrepo.noarch .rpm
sudo yum clean all
sudo yum update
sudo yum install flash*
service plexmediaserver start
rpm -Uvh http://dl.fedoraproject.org/pub/epel/beta/7/x86_64/epel-rele ase-7-0.2.noarch.rpm && rpm -Uvh http://li.nux.ro/download/nux/dextop/el7/x86_64/nux-dextop-r elease-0-1.el7.nux.noarch.rpm
sudo rpm -Uvh http://dl.fedoraproject.org/pub/epel/beta/7/x86_64/epel-rele ase-7-0.2.noarch.rpm && rpm -Uvh http://li.nux.ro/download/nux/dextop/el7/x86_64/nux-dextop-r elease-0-1.el7.nux.noarch.rpm
sudo rpm -Uvh http://li.nux.ro/download/nux/dextop/el7/x86_64/nux-dextop-r elease-0-1.el7.nux.noarch.rpm
sudo yum clean all
sudo yum update
sudo yum install kmod-nvidia
sudo yum install vlc
sudo yum install HandBrake-gui
sudo yum install HandBrake-cli
HandBrake
HandBrake-gui
which HandBrake
sudo yum erase glamor
sudo yum erase xorg-x11-glamor
exit
sudo yum install h.264
sudo install yumex
sudo yum install yumex
cvlc --verbose 2
ffmpeg
sudo yum install ffmpeg
gedit /etc/ld.so.conf.d/ffmpeg-compat.conf
sudo service start plexmediacenter
service plexmediaserver start
sudo service plexmediaserver start
dmesg
which ffmpeg
ffmpeg --help
ffmpeg
rpm -qi libva
rpm -qi libvapau
sudo yum install libvapau
rpm -qi libvdpau
sudo yum install vlc-core
sudo yum remove plexmediaserver
sudo yum remove vlc
rpm -qR plexmediaserver
rpm -qpR plexmediaserver
vlc --reset-config
sudo yum install yumex
vlc
HandBrake
HandBrake-cli
HandBrake-gui
HandBrake
which HandBrake
which HandBrake-gui
HandBrakeCLI
sudo yum install libass.so.4
sudo yum whoprovides libass.so.4
sudo yum -whoprovides libass.so.4
sudo yum -provides libass.so.4
sudo yum provides libass.so.4
sudo yum provides libass
sudo yum install libass
HandBrakeCLI
sudo yum install libfribidi
HandBrakeCLI
HandBrakeGUI
HandBrake
which fuse
which ntfs-3g
sudo yum install ntfs-3g
sudo yum install fuse
sudo yum install ntfs
sudo yum install ntfs-3g
Re: VLC 2.1.4 Decoder Errors [message #1843 is a reply to message #1837] Sat, 12 July 2014 01:04 Go to previous messageGo to next message
nux is currently offline  nux
Messages: 1662
Registered: January 2012
Senior Member
Administrator

That was quite an adventure, your bash history. Smile
Anyhow, I can't explain why you would get those errors in VLC, unless Plex does something behind the scenes.
Would I be able to try out the video that is failing for you?

Also, have you managed to play any of the files I linked for you previously (big buck bunny)?
Re: VLC 2.1.4 Decoder Errors [message #1844 is a reply to message #1843] Sat, 12 July 2014 01:19 Go to previous messageGo to next message
crxtasy12 is currently offline  crxtasy12
Messages: 5
Registered: July 2014
Junior Member
Sorry forgot to add that I didn't get them to play. Same error. I'm leaning towards it being plex's fault. The files work in totem. Plex comes with all the video codecs to play and transcode files on the fly. I will post on the forum and see if they know what the problem may be. Most people who use plex are just using it on a server and not on a workstation. I have a full desktop. And I like to use VLC. Thanks for the help
Re: VLC 2.1.4 Decoder Errors [message #1845 is a reply to message #1837] Sat, 12 July 2014 16:59 Go to previous messageGo to next message
SpaceBack is currently offline  SpaceBack
Messages: 24
Registered: September 2012
Junior Member
Dedoimedo posted an article about the same error that you are getting.
http://www.dedoimedo.com/computers/vlc-codec-errors.html
Re: VLC 2.1.4 Decoder Errors [message #1926 is a reply to message #1837] Fri, 25 July 2014 07:52 Go to previous messageGo to next message
crxtasy12 is currently offline  crxtasy12
Messages: 5
Registered: July 2014
Junior Member
Sorry forgot to report back. I only have Nux, EPEL, and elrepo installed. But the article made me look at the files and everything was in there so I thought maybe it couldn't find it or something was pointing somewhere else. Seems Plex comes with the codecs too so to fix the problem. I uninstalled plex and vlc and then installed vlc first. I tested a file and that worked, I had video again. I then install plex and now everything is working fine. Thanks for the help everyone.
Re: VLC 2.1.4 Decoder Errors [message #1933 is a reply to message #1837] Fri, 25 July 2014 15:28 Go to previous message
nux is currently offline  nux
Messages: 1662
Registered: January 2012
Senior Member
Administrator

Glad you got it working, watch out for future conflicts.
Previous Topic: gstreamer-vaapi and libva-freeworld for el7
Next Topic: Package request: mtpaint (el7)
Goto Forum:
  


Current Time: Thu Oct 17 13:59:37 BST 2019

Total time taken to generate the page: 0.01109 seconds