Nux!


Home » Repos » Report a problem or request a package » gvfs permission and gnome-shell animation (gvfs permission problem with find command and unable to disable gnome-shell animations)
gvfs permission and gnome-shell animation [message #1877] Mon, 21 July 2014 05:12 Go to next message
mitu is currently offline  mitu
Messages: 85
Registered: February 2012
Location: gurgaon, new delhi, india
Member
Overall, I'm having a smooth experience on Centos 7 + stella repo except two annoyances, please suggest me how to fix them.

#1 I'm unable to disable gnome-shell animations. Changing the settings using gsettings command disables for the current session only, after reboot the animations are back like a ghost. Suggest me how to disable animations permanently.

#2 While using "find" I get some weird gvfs permission error message:

find: `./run/user/1000/gvfs`: Permission denied

As far as I remember it happened after I removed the centos repo libreoffice with those from libreoffice.com. During installation it pulled some gnome-vfs package as a dependency to libreoffice-gnome-integration package. It's very annoying.
Re: gvfs permission and gnome-shell animation [message #1878 is a reply to message #1877] Mon, 21 July 2014 08:51 Go to previous messageGo to next message
nux is currently offline  nux
Messages: 1662
Registered: January 2012
Senior Member
Administrator

Hi,

1. What animations are you talking about exactly?

2. The error seems normal. I would imagine you are not the user with UID 1000. In the same way you would not be able to access /home/otheruser or some of the /proc directories. Just put up with it. Smile
Re: gvfs permission and gnome-shell animation [message #1879 is a reply to message #1878] Mon, 21 July 2014 09:07 Go to previous messageGo to next message
mitu is currently offline  mitu
Messages: 85
Registered: February 2012
Location: gurgaon, new delhi, india
Member
Thanks Nux for such prompt reply. Here are explanations inline.

1. What animations are you talking about exactly?

Gnome-shell animations (minimization, maximization, window movement) and the hot corner.

2. The error seems normal. I would imagine you are not the user with UID 1000. In the same way you would not be able to access /home/otheruser or some of the /proc directories. Just put up with it. Smile

This error message comes up even when I use "find" command as a root user. Besides, it was not showing before I installed libreoffice which installed gnome-vfs2-2.24.4-14.el7.x86_64.rpm as a dependency. I guess it's messing up with gvfs-1.16.4-7.el7.x86_64.rpm (and few other gvfs-*** packages). Well, find command works as it should but it throws that error message after listing the found items. Is there any workaround to mask something or comment out a line somewhere so as to stop this error message.

PS: did you check my thread on vaapi? vaapi is working as it should after installing gstreamer1-vaapi from your repo and libva from atrpms.

[Updated on: Mon, 21 July 2014 09:41]

Report message to a moderator

[solved] gvfs permission and gnome-shell animation [message #1899 is a reply to message #1879] Tue, 22 July 2014 10:30 Go to previous messageGo to next message
mitu is currently offline  mitu
Messages: 85
Registered: February 2012
Location: gurgaon, new delhi, india
Member
#1 To completely disable animations on gnome-shell 3.8, now it takes two steps:

First: gsettings set org.gnome.settings-daemon.plugins.remote-display active false
Second: gsettings set org.gnome.desktop.interface enable-animations false

#2 To completely disable hot corner mouseover effect, we have to edit file /usr/share/gnome-shell/js/ui/layout.js

Then find this code:

this._corner = new Clutter.Rectangle({ name: 'hot-corner',
width: 1,
height: 1,
opacity: 0,
reactive: true });

Finally, there replace "reactive: true" with "reactive: false"

#3 To stop that gvfs error, I removed libreoffice packages (those were installed libreoffice.com) and gnome-vfs, then I installed libreoffice packages from Centos repo.
Re: gvfs permission and gnome-shell animation [message #1902 is a reply to message #1877] Tue, 22 July 2014 11:06 Go to previous messageGo to next message
nux is currently offline  nux
Messages: 1662
Registered: January 2012
Senior Member
Administrator

Thanks for the tips. Smile
Re: gvfs permission and gnome-shell animation [message #1908 is a reply to message #1902] Tue, 22 July 2014 11:41 Go to previous message
mitu is currently offline  mitu
Messages: 85
Registered: February 2012
Location: gurgaon, new delhi, india
Member
all my pleasure!

But here's word of caution. That "gvfs error message" was specific to me. It may not stop "`./run/user/1000/gvfs`: Permission denied" for all. Cos, of late I came to know there are several other things that leads to this message, and gnome-vfs is just one of them.

[Updated on: Tue, 22 July 2014 11:43]

Report message to a moderator

Previous Topic: EPEL-7 update of libass breaks some dependencies
Next Topic: (upgrade) Synergy
Goto Forum:
  


Current Time: Wed Oct 23 21:17:50 BST 2019

Total time taken to generate the page: 0.00806 seconds