Nux!


Home » Stella » Report a problem or request a feature » MATE el7 issues (-- no login sound -- logout crashes)
MATE el7 issues [message #2018] Mon, 04 August 2014 04:52 Go to next message
ongoto is currently offline  ongoto
Messages: 173
Registered: October 2013
Location: California USA
Senior Member
No login sound in CentOS7 MATE. For the moment I'm using this work around.


System->Control Panel->Sounds
Change [system sounds] to Default and uncheck Mute.
Close

Copy /usr/share/gnome/autostart/libcanberra-login-sound.desktop to
/home/user/.config/autostart/
Note: don't destroy the original...you have some editing to do.

Open /home/user/.config/autostart/libcanberra-login-sound.desktop in geany or vim
#!/usr/bin/env xdg-open
[Desktop Entry]
Type=Application
Name=MATE Login Sound
Comment=Plays a sound whenever you log in
Exec=/usr/bin/canberra-gtk-play --id="service-login" --description="MATE Login"
OnlyShowIn=MATE;
AutostartCondition=GSettings org.gnome.desktop.sound event-sounds
X-MATE-Autostart-Phase=Application
X-MATE-Provides=login-sound
X-MATE-Autostart-enabled=true

Replace 'GNOME' with 'MATE' as shown above. Change '--id="desktop-login"' to
'--id="service-login"' as shown. Add 'X-MATE-Autostart-enabled=true' (optional)
Then save

MATE Login sound should now appear in
System->Control Panel->Startup Applications

Voila!

Set your sound volume and reboot to test.

Note: I say reboot because logout crashes my system??
What you can do is Ctrl+Alt+F2 and login as root. Then do
killall gdm and log back in.


[Updated on: Tue, 05 August 2014 00:06]

Report message to a moderator

Re: MATE el7 issues [message #2026 is a reply to message #2018] Tue, 05 August 2014 02:35 Go to previous messageGo to next message
ongoto is currently offline  ongoto
Messages: 173
Registered: October 2013
Location: California USA
Senior Member
The previous post is MATE specific. I've streamlined it a bit in an attempt to make it work
with Gnome3 as well. I'd prefer to put it in /etc/xdg/autostart/ but Gnome3 doesn't find it ?? I dunno.
So, for now, it has to be /home/user/.config/autostart/libcanberra-login-sound.desktop

#!/usr/bin/env xdg-open
[Desktop Entry]
Type=Application
Name=Login Sound
Comment=Plays a sound whenever you log in
Exec=/usr/bin/canberra-gtk-play --id="service-login" --description="GNOME Login"
AutostartCondition=GSettings org.gnome.desktop.sound event-sounds
Autostart-enabled=true

P.S. Also, Gnome3 doesn't have the logout issue

[Updated on: Tue, 05 August 2014 02:38]

Report message to a moderator

Re: MATE el7 issues [message #2029 is a reply to message #2018] Tue, 05 August 2014 09:21 Go to previous messageGo to next message
nux is currently offline  nux
Messages: 1650
Registered: January 2012
Senior Member
Administrator

Wow, the kind of bugs you guys hit, I should count myself lucky not to hit such exotic issues. Very Happy
I guess waiting for 7.1 might not be such a bad idea, there seem to be a lot of bugs to pan out.
Re: MATE el7 issues [message #2031 is a reply to message #2029] Tue, 05 August 2014 11:36 Go to previous messageGo to next message
ongoto is currently offline  ongoto
Messages: 173
Registered: October 2013
Location: California USA
Senior Member
Laughing Laughing Laughing
We're just getting started.
I have a couple more if I can ever figure out how to explain 'em. Embarrassed

Update:
Oops! spoke too soon. One problem went away.
I have no idea why or how, but the Mate logout issue is solved.
Gremlins went to sleep maybe??? Razz

[Updated on: Tue, 05 August 2014 13:09]

Report message to a moderator

Re: MATE el7 issues [message #2148 is a reply to message #2031] Sun, 10 August 2014 10:45 Go to previous message
ongoto is currently offline  ongoto
Messages: 173
Registered: October 2013
Location: California USA
Senior Member
RE: Logout crashes

Well...The problem came back!
I think it's solved now though. It seems to have gone away after reinstalling mate-session-manager from epel.
Fingers crossed. Wish me luck. Smile

[Updated on: Sun, 10 August 2014 10:53]

Report message to a moderator

Previous Topic: Gnome and Mate el7
Next Topic: Missing from Mate el7
Goto Forum:
  


Current Time: Sun Mar 24 17:33:36 GMT 2019

Total time taken to generate the page: 0.00984 seconds