Nux!


Home » Repos » Report a problem or request a package » Package conflict between CentOS 6.6 cr and nux-desktop repos (pywebkitgtk, webkitgtk and Midori)
Package conflict between CentOS 6.6 cr and nux-desktop repos [message #2628] Thu, 23 October 2014 19:51 Go to next message
caitlyn is currently offline  caitlyn
Messages: 6
Registered: March 2014
Location: North Carolina, United St...
Junior Member
My latest update to my one and only system still running Stella 6 returned these errors:

Resolving Dependencies
--> Running transaction check
---> Package pywebkitgtk.i686 0:1.1.6-3.el6 will be updated
---> Package pywebkitgtk.i686 0:1.1.6-4.el6 will be an update
---> Package webkitgtk.i686 0:1.2.6-5.el6 will be updated
--> Processing Dependency: libwebkit-1.0.so.2 for package: midori-0.4.3-1.el6.nux.i686
---> Package webkitgtk.i686 0:1.4.3-8.el6 will be an update
--> Running transaction check
---> Package webkitgtk.i686 0:1.2.6-5.el6 will be updated
---> Package webkitgtk.i686 0:1.4.3-8.el6 will be an update
--> Processing Dependency: libwebkitgtk-1.0.so.0 for package: pywebkitgtk-1.1.6-4.el6.i686

Packages skipped because of dependency problems:
    pywebkitgtk-1.1.6-4.el6.i686 from cr
    webkitgtk-1.4.3-8.el6.i686 from cr


Basically, pywebkitgtk and webkitgtk updates create a dependency conflict with the version of midori in the nux-desktop repo. I'm also testing Vector Linux 7.1 RC2.3 on my 32 bit hardware and they have a much newer versiop or midori that works well. Any chance of an updated midori package to both resolve this problem and bring the browser up to date?

(Yes, I could build it myself but better to have it in the repo.)

Thanks.

[Updated on: Thu, 23 October 2014 19:51]

Report message to a moderator

Re: Package conflict between CentOS 6.6 cr and nux-desktop repos [message #2629 is a reply to message #2628] Thu, 23 October 2014 21:38 Go to previous messageGo to next message
nux is currently offline  nux
Messages: 1659
Registered: January 2012
Senior Member
Administrator

Hi caitlyn , I'll try to update it, but I remember having problems with newer versions (too old deps in EL6 ... as usual :> ).
Re: Package conflict between CentOS 6.6 cr and nux-desktop repos [message #2631 is a reply to message #2628] Thu, 23 October 2014 22:13 Go to previous messageGo to next message
nux is currently offline  nux
Messages: 1659
Registered: January 2012
Senior Member
Administrator

I have added midori-0.4.4-1, let me know if it solves the problem. Can't build newer due to too old Vala...
Re: Package conflict between CentOS 6.6 cr and nux-desktop repos [message #2643 is a reply to message #2631] Sat, 25 October 2014 21:53 Go to previous messageGo to next message
caitlyn is currently offline  caitlyn
Messages: 6
Registered: March 2014
Location: North Carolina, United St...
Junior Member
Yum is still only finding midori-0.4.3-1.el6.nux.i686 (@nux-dextop). Is there another repository I need to enable?
Re: Package conflict between CentOS 6.6 cr and nux-desktop repos [message #2645 is a reply to message #2628] Sat, 25 October 2014 23:21 Go to previous messageGo to next message
nux is currently offline  nux
Messages: 1659
Registered: January 2012
Senior Member
Administrator

Meh, the 32bit package did not get uploaded, fixing now. Sorry Sad
Re: Package conflict between CentOS 6.6 cr and nux-desktop repos [message #2652 is a reply to message #2645] Mon, 27 October 2014 17:35 Go to previous messageGo to next message
constantin is currently offline  constantin
Messages: 82
Registered: July 2014
Location: Ukraine
Member
Hi!
New webkitgtk package provides libwebkit-1.0.so.2 as a symlink to libwebkitgtk-1.0.so.0.7.3. And all packages, required libwebkit-1.0.so.2 WILL work. But libwebkit-1.0.so.2 is not in PROVIDES section of rpm. It's a bug in cr webkitgtk package. I have encountered this problem with shotwell-fc13 (which also could not be rebuilt with new vala). Installation with --nodeps will force the package to work.
Re: Package conflict between CentOS 6.6 cr and nux-desktop repos [message #2655 is a reply to message #2628] Mon, 27 October 2014 19:38 Go to previous message
nux is currently offline  nux
Messages: 1659
Registered: January 2012
Senior Member
Administrator

Hi,

In midori's case it was not needed, I built a newer package against the new libs and it was fine.
Previous Topic: libfm for el7
Next Topic: Package request: avidemux (el7)
Goto Forum:
  


Current Time: Fri Jun 21 00:05:17 BST 2019

Total time taken to generate the page: 0.00942 seconds