Nux!


Home » Stella » Report a problem or request a feature » vlc can't disable kde screensaver (centos 7: vlc can't disable kde screensaver)
vlc can't disable kde screensaver [message #2829] Sat, 20 December 2014 02:27 Go to next message
mitu is currently offline  mitu
Messages: 85
Registered: February 2012
Location: gurgaon, new delhi, india
Member
vlc is unable to disable screensaver while playing any video on centos 7 64bit kde. i googled a lot but can't come up with any solution. most of the search results where kinda blame game - vlc people saying it's a kde bug and vice versa. plz anybody suggest a fix.
Re: vlc can't disable kde screensaver [message #2830 is a reply to message #2829] Sat, 20 December 2014 15:38 Go to previous messageGo to next message
nux is currently offline  nux
Messages: 1659
Registered: January 2012
Senior Member
Administrator

Is there a way to disable the kde screensaver from command line? If yes, then you could do something like the following work around:

1. mv /usr/bin/vlc /usr/bin/vlc.real
2. create /usr/bin/vlc with a content such as the following and make it executable:

#!/bin/sh
disable screensaver ; /usr/bin/vlc.real "$@" ; enable screensaver


So when you'll open something with /usr/bin/vlc, that shell wrapper will disable the screensaver for the duration of running VLC.

Does it help you?

[Updated on: Sat, 20 December 2014 15:39]

Report message to a moderator

Re: vlc can't disable kde screensaver [message #2831 is a reply to message #2830] Sat, 20 December 2014 18:05 Go to previous messageGo to next message
mitu is currently offline  mitu
Messages: 85
Registered: February 2012
Location: gurgaon, new delhi, india
Member
yeah, i believe "xset s off" disables screensaver, and "xset s on" enables it in the commandline. so, i've to use:

#!/bin/sh
xset s off ; /usr/bin/vlc.real "$@" ; xset s on (after following those 1 and 2 steps)
Re: vlc can't disable kde screensaver [message #2832 is a reply to message #2829] Sat, 20 December 2014 22:56 Go to previous messageGo to next message
nux is currently offline  nux
Messages: 1659
Registered: January 2012
Senior Member
Administrator

About right.

HTH
Re: vlc can't disable kde screensaver [message #2833 is a reply to message #2832] Sun, 21 December 2014 03:30 Go to previous messageGo to next message
mitu is currently offline  mitu
Messages: 85
Registered: February 2012
Location: gurgaon, new delhi, india
Member
yes, it worked! thx nux.
Re: vlc can't disable kde screensaver [message #2836 is a reply to message #2829] Sun, 21 December 2014 12:04 Go to previous messageGo to next message
nux is currently offline  nux
Messages: 1659
Registered: January 2012
Senior Member
Administrator

Np, keep in mind the next vlc update will overwrite your wrapper.
Re: vlc can't disable kde screensaver [message #2837 is a reply to message #2836] Sun, 21 December 2014 17:56 Go to previous message
mitu is currently offline  mitu
Messages: 85
Registered: February 2012
Location: gurgaon, new delhi, india
Member
yeah, i'll take care. thx for the info.
Previous Topic: no native kde4 webcam utility for centos 7
Next Topic: Automount not working in GNOME
Goto Forum:
  


Current Time: Thu Jun 20 15:14:20 BST 2019

Total time taken to generate the page: 0.01678 seconds