Nux!


Home » Stella » Report a problem or request a feature » Automount not working in GNOME
Automount not working in GNOME [message #2861] Sat, 27 December 2014 19:15 Go to next message
serengeti is currently offline  serengeti
Messages: 2
Registered: December 2014
Location: Poland
Junior Member
Hi,
first of all, thanks for a great distro! It made my dad's old Thinkpad T42 (Pentium M 1.6) usable again. The machine's become fast enough to play 720p video in MPlayer Smile

The issue I'm having is that FAT and NTFS USB sticks are not mounted automatically. When I plug them in, dmesg shows that the new device is being recognized, and I can mount them from the command line or by using GNOME's Disk Utility, but I'd rather it happened automatically... Any clues?

[Updated on: Sat, 27 December 2014 19:16]

Report message to a moderator

Re: Automount not working in GNOME [message #2863 is a reply to message #2861] Sat, 27 December 2014 19:39 Go to previous messageGo to next message
nux is currently offline  nux
Messages: 1659
Registered: January 2012
Senior Member
Administrator

Hm, this is definitely abnormal behaviour. Anything in /var/log/messages?
Re: Automount not working in GNOME [message #2866 is a reply to message #2863] Sun, 28 December 2014 22:42 Go to previous messageGo to next message
serengeti is currently offline  serengeti
Messages: 2
Registered: December 2014
Location: Poland
Junior Member
Thanks for answering! The following appears in /var/log/messages when I connect the usb stick:

Dec 28 23:35:09 localhost kernel: usb 1-3: new high-speed USB device number 2 using ehci-pci
Dec 28 23:35:09 localhost kernel: usb 1-3: New USB device found, idVendor=0930, idProduct=6544
Dec 28 23:35:09 localhost kernel: usb 1-3: New USB device strings: Mfr=1, Product=2, SerialNumber=3
Dec 28 23:35:09 localhost kernel: usb 1-3: Product: TransMemory     
Dec 28 23:35:09 localhost kernel: usb 1-3: Manufacturer: TOSHIBA 
Dec 28 23:35:09 localhost kernel: usb 1-3: SerialNumber: 5A91596AEA7DCE3062FA30EF
Dec 28 23:35:09 localhost kernel: usb-storage 1-3:1.0: USB Mass Storage device detected
Dec 28 23:35:09 localhost kernel: scsi2 : usb-storage 1-3:1.0
Dec 28 23:35:09 localhost kernel: usbcore: registered new interface driver usb-storage
Dec 28 23:35:10 localhost kernel: scsi 2:0:0:0: Direct-Access     TOSHIBA  TransMemory      1.00 PQ: 0 ANSI: 4
Dec 28 23:35:10 localhost kernel: sd 2:0:0:0: Attached scsi generic sg2 type 0
Dec 28 23:35:10 localhost kernel: sd 2:0:0:0: [sdb] 30310400 512-byte logical blocks: (15.5 GB/14.4 GiB)
Dec 28 23:35:10 localhost kernel: sd 2:0:0:0: [sdb] Write Protect is off
Dec 28 23:35:10 localhost kernel: sd 2:0:0:0: [sdb] Write cache: disabled, read cache: enabled, doesn't support DPO or FUA
Dec 28 23:35:10 localhost kernel: sdb: sdb1
Dec 28 23:35:10 localhost kernel: sd 2:0:0:0: [sdb] Attached SCSI removable disk


And when I mount the partition with palimpsest:

Dec 28 23:38:33 localhost ntfs-3g[2336]: Version 2014.2.15 integrated FUSE 27
Dec 28 23:38:33 localhost ntfs-3g[2336]: Mounted /dev/sdb1 (Read-Write, label "TOSHIBA", NTFS 3.1)
Dec 28 23:38:33 localhost ntfs-3g[2336]: Cmdline options: rw,nosuid,nodev,uhelper=udisks,uid=500,gid=500,dmask=0077
Dec 28 23:38:33 localhost ntfs-3g[2336]: Mount options: rw,nosuid,nodev,uhelper=udisks,allow_other,nonempty,relatime,default_permissions,fsname=/dev/sdb1,blkdev,blksize=4096
Dec 28 23:38:33 localhost ntfs-3g[2336]: Global ownership and permissions enforced, configuration type 1
Re: Automount not working in GNOME [message #2878 is a reply to message #2861] Mon, 29 December 2014 18:19 Go to previous messageGo to next message
nux is currently offline  nux
Messages: 1659
Registered: January 2012
Senior Member
Administrator

Can you open Nautilus -> Preferences -> Media and check if there is anything you can tweak there?
This is how mine looks (though in MATE/EL7): http://i.imgur.com/L00v3Ma.png

icon12.gif  Re: Automount not working in GNOME [message #2880 is a reply to message #2878] Mon, 29 December 2014 22:09 Go to previous messageGo to next message
detipco is currently offline  detipco
Messages: 294
Registered: March 2014
Senior Member
USB sticks normally never automounted, that`s not a problem of Gnome.
It`s not possible to manage it in "settings > details > media", these settings are not available in nautilus like caja!
You have to install "autofs" to manage it. https://wiki.archlinux.org/index.php/autofs or install caja.

Only a friendly pointer Smile

[Updated on: Mon, 29 December 2014 22:50]

Report message to a moderator

Re: Automount not working in GNOME [message #2881 is a reply to message #2861] Tue, 30 December 2014 00:40 Go to previous message
nux is currently offline  nux
Messages: 1659
Registered: January 2012
Senior Member
Administrator

S, if you open Nautilus in EL6, you don't see the usb stick on the left hand side, in the volume listing?
Previous Topic: vlc can't disable kde screensaver
Next Topic: Avidemux Problems in Centos 7
Goto Forum:
  


Current Time: Mon Jun 24 22:52:40 BST 2019

Total time taken to generate the page: 0.04209 seconds