Nux!


Home » Stella » Report a problem or request a feature » Upgrade fails missing x264-libs (upgrade from 6.5 to 6.6 via yum update fails on libquicktime requiring missing libx264)
Upgrade fails missing x264-libs [message #2966] Fri, 23 January 2015 04:03 Go to next message
mogga
Messages: 9
Registered: October 2014
Location: Los Angeles, CA
Junior Member
Hey nux,

Getting the following error when trying to upgrade from 6.5 to 6.6

Error: Package: libquicktime-1.2.4-1.el6.nux.x86_64 (@nux-dextop)
           Requires: libx264.so.120()(64bit)
           Removing: x264-libs-0.120-5.20120303.el6.nux.x86_64 (@nux-dextop/$releasever)
               libx264.so.120()(64bit)
           Updated By: x264-libs-0.142-7.20140728gitaf8e768.el6.nux.x86_64 (nux-dextop)
               Not found
           Available: x264-libs-0.120-6.20120303.el6.nux.x86_64 (nux-dextop)
               libx264.so.120()(64bit)
           Available: x264-libs-0.0.0-0.28.20100706gitd058f37.el6.nux.x86_64 (nux-dextop)
               Not found
           Available: x264-libs-0.0.0-0.31.20110811.el6.nux.x86_64 (nux-dextop)
               Not found



Solved by removing x264-libs which removed the following packages on my system: ffmpeg-libs,libquicktime, mencoder, gstreamer-ffmpeg, gstreamer-plugins-ugly, mlt, mlt-python, mplayer, mplayer-gui, mplayer-tools

Then update...

yum update


After a reboot...

yum update
yum install x264-libs
yum install ffmpeg-libs gstreamer-ffmpeg gstreamer-plugins-ugly libquicktime mencoder mlt mlt-python mplayer mplayer-gui mplayer-tools

[Updated on: Fri, 23 January 2015 05:06]

Report message to a moderator

Re: Upgrade fails missing x264-libs [message #2967 is a reply to message #2966] Fri, 23 January 2015 08:28 Go to previous messageGo to next message
nux is currently offline  nux
Messages: 1663
Registered: January 2012
Senior Member
Administrator

Hi,

Yes, sorry about that, I have seen it before, though I failed to find a solution, the versions are clearly higher and that should not happen, but clearly it does.
I'll need to insist on this issue, I guess.
Re: Upgrade fails missing x264-libs [message #2969 is a reply to message #2967] Fri, 23 January 2015 18:44 Go to previous messageGo to next message
mogga
Messages: 9
Registered: October 2014
Location: Los Angeles, CA
Junior Member
yup. documenting here so others know the solution.
Re: Upgrade fails missing x264-libs [message #3004 is a reply to message #2966] Thu, 05 February 2015 22:16 Go to previous message
nux is currently offline  nux
Messages: 1663
Registered: January 2012
Senior Member
Administrator

this has been fixed btw, "yum update" should run smoothly now
Previous Topic: Centos Plus kernel for Stella
Next Topic: Won't start GUI after update
Goto Forum:
  


Current Time: Thu Apr 02 15:38:08 BST 2020

Total time taken to generate the page: 0.03879 seconds