Nux!


Home » Repos » Report a problem or request a package » vlc failed on Centos 7.0
vlc failed on Centos 7.0 [message #3079] Wed, 18 March 2015 11:46 Go to next message
als123 is currently offline  als123
Messages: 4
Registered: March 2015
Junior Member
I recently tried installing Centos 7.0 and installed vlc.
What I did was

yum --disablerepo=\* --enablerepo=nux-dextop install x264-libs
yum --disablerepo=atrpms install vlc

Installed:
vlc.x86_64 0:2.1.5-2.el7.nux

Dependency Installed:
a52dec.x86_64 0:0.7.4-18.el7.nux
faad2-libs.x86_64 1:2.7-5.el7.nux
ffmpeg-libs.x86_64 0:2.3.4-2.el7.nux
libcddb.x86_64 0:1.3.2-12.el7.nux
libdca.x86_64 0:0.0.5-7.el7.nux
libdvbpsi.x86_64 0:0.2.2-3.el7.nux
libmad.x86_64 0:0.15.1b-16.el7.nux
libmpeg2.x86_64 0:0.5.1-10.el7.nux
live555.x86_64 0:2013.11.26-1.el7.nux
twolame-libs.x86_64 0:0.3.13-3.el7.nux
vlc-core.x86_64 0:2.1.5-2.el7.nux
xvidcore.x86_64 0:1.3.2-5.el7.nux
zvbi.x86_64 0:0.2.33-16.el7.nux

aalib-libs.x86_64 0:1.4.0-0.22.rc5.el7
dirac-libs.x86_64 0:1.0.2-14.el7
enca.x86_64 0:1.14-1.el7
freeglut.x86_64 0:2.8.1-3.el7
fribidi.x86_64 0:0.19.4-6.el7
game-music-emu.x86_64 0:0.6.0-5.el7
lame-libs.x86_64 0:3.99.5-2.el7
libass.x86_64 0:0.12.0-1.el7
libcaca.x86_64 0:0.99-0.17.beta17.el7
libchromaprint.x86_64 0:1.0-1.el7
libdc1394.x86_64 0:2.2.2-3.el7
libebml.x86_64 0:1.3.0-1.el7
libkate.x86_64 0:0.4.1-4.el7
libmatroska.x86_64 0:1.4.1-1.el7
libmodplug.x86_64 1:0.8.8.5-3.el7
libmtp.x86_64 0:1.1.6-3.el7
libtiger.x86_64 0:0.3.4-7.el7
libupnp.x86_64 0:1.6.19-2.el7
libva.x86_64 0:1.2.1-3.el7
lirc-libs.x86_64 0:0.9.1a-4.el7
minizip.x86_64 0:1.2.7-13.el7
openal-soft.x86_64 0:1.16.0-2.el7
schroedinger.x86_64 0:1.0.11-4.el7
SDL_image.x86_64 0:1.2.12-11.el7
soxr.x86_64 0:0.1.1-3.el7
xcb-util-keysyms.x86_64 0:0.3.9-5.el7

The result was a vlc that could not play movies. It claimed to
not know about the mp4 and h264 file formats.

I can't test this again but I'm thinking that if I had
included mplayer then this would have provided the necessary
codecs. Does this sound plausible?
Re: vlc failed on Centos 7.0 [message #3080 is a reply to message #3079] Wed, 18 March 2015 14:29 Go to previous messageGo to next message
nux is currently offline  nux
Messages: 1659
Registered: January 2012
Senior Member
Administrator

Can you install mplayer and see if this solves it?

However the problem seems bigger than this, seeing that you also have ATrpms enabled, I think it may have to do with that.
I can play MP4 and MOV files just fine with VLC, tested with Big Buck Bunny files.
Re: vlc failed on Centos 7.0 [message #3082 is a reply to message #3080] Wed, 18 March 2015 15:41 Go to previous messageGo to next message
detipco is currently offline  detipco
Messages: 294
Registered: March 2014
Senior Member
Seems that there is also missing libdvdcss and x264-libs from nux.
Do you have them installed?

VLC is not correct installed, there is also vlc-extras missing.

[Updated on: Wed, 18 March 2015 16:04]

Report message to a moderator

Re: vlc failed on Centos 7.0 [message #3084 is a reply to message #3079] Wed, 18 March 2015 22:05 Go to previous messageGo to next message
als123 is currently offline  als123
Messages: 4
Registered: March 2015
Junior Member
The yum lines show that I disabled the atrpms repo and downloaded
x264-libs explicitly. I also downloaded vlc-extras but it appeared
to be empty.

I'm not going to continue with Centos 7.0 for other reasons. I'll
probably switch to openSuse. I just posted in case there was
something obvious I was doing wrong.
Re: vlc failed on Centos 7.0 [message #3088 is a reply to message #3084] Thu, 19 March 2015 22:37 Go to previous messageGo to next message
detipco is currently offline  detipco
Messages: 294
Registered: March 2014
Senior Member
Hi als123,
it`s really not an issue on CentOS.
I`ve running vlc too without any problem.
If you think switching to openSuse will solve your problem, is this the best way for you.

BTW, all rpm based OS do have the same issues. Maybe it`s better to switch to LM.

friendly regards Smile
Re: vlc failed on Centos 7.0 [message #3089 is a reply to message #3088] Fri, 20 March 2015 03:43 Go to previous messageGo to next message
als123 is currently offline  als123
Messages: 4
Registered: March 2015
Junior Member
Off topic, but Centos 7.0 includes KDE but omits, believe it or not, kmail.
I did not find this out until after having trouble installing vlc.
openSuse is a distro that takes KDE more seriously.
Re: vlc failed on Centos 7.0 [message #3090 is a reply to message #3089] Fri, 20 March 2015 08:06 Go to previous messageGo to next message
detipco is currently offline  detipco
Messages: 294
Registered: March 2014
Senior Member
CentOs isn`t a KDE distro, standing always for Gnome.
I never liked and used KDE, so I can`t say something about.
I`m using now CentOS el7 nux with Cinnamon and I really like it.
Have a look https://forums.nux.ro/index.php?t=msg&th=533&start=0 &S=4a47e0b426720dd64d8218cc26f2c9ab

BTW, I don`t like opensuse, it`s too german messy. They always wanna make it perfect, but it`s getting always messy.

friendly regards

[Updated on: Fri, 20 March 2015 08:09]

Report message to a moderator

Re: vlc failed on Centos 7.0 [message #3094 is a reply to message #3079] Fri, 20 March 2015 23:53 Go to previous messageGo to next message
nux is currently offline  nux
Messages: 1659
Registered: January 2012
Senior Member
Administrator

Yes, CentOS is not the best option if you're a KDE fan. Perhaps try Kubuntu or Rosa Linux.

Re: vlc failed on Centos 7.0 [message #3096 is a reply to message #3094] Sat, 21 March 2015 08:10 Go to previous message
detipco is currently offline  detipco
Messages: 294
Registered: March 2014
Senior Member
A good option for a KDE fan is also this one http://distrowatch.com/table.php?distribution=pclinuxos
Previous Topic: website problems
Next Topic: exaile R.I.P. after updating
Goto Forum:
  


Current Time: Sun Jun 16 17:48:00 BST 2019

Total time taken to generate the page: 0.01309 seconds