Nux!


Home » Stella » General chat » avoid update problems (el7)
avoid update problems [message #3098] Sat, 21 March 2015 16:38 Go to next message
detipco is currently offline  detipco
Messages: 294
Registered: March 2014
Senior Member
Hi nux,
I wanna avoid update problems like exaile.
Is there an effect in changing the settings of the files yum-cron.conf and yum-cron-hourly.conf?
I only need security updates and not always the newest version. ( = yum upgrade )
My intention is to upgrade only what I want, so I`m not overtaken in broken packages.

#  What kind of update to use:
# default                            = yum upgrade
# security                           = yum --security upgrade
# security-severity:Critical         = yum --sec-severity=Critical upgrade
# minimal                            = yum --bugfix upgrade-minimal
# minimal-security                   = yum --security upgrade-minimal
# minimal-security-severity:Critical =  --sec-severity=Critical upgrade-minimal
update_cmd = default


By default update is "update_cmd = default".
I wanna change it to "update_cmd = security".
What do you think?

friendly regards





Re: avoid update problems [message #3099 is a reply to message #3098] Sat, 21 March 2015 17:03 Go to previous messageGo to next message
detipco is currently offline  detipco
Messages: 294
Registered: March 2014
Senior Member
Just tested it, but I`m still getting an update for exaile.
Seems not to work like I want. Crying or Very Sad
Re: avoid update problems [message #3102 is a reply to message #3098] Sat, 21 March 2015 19:54 Go to previous messageGo to next message
nux is currently offline  nux
Messages: 1586
Registered: January 2012
Senior Member
Administrator

Security only updates do not work on CentOS (yet).
You can add exaile in excludepkgs= in /etc/yum.repos.d/epel.repo

Re: avoid update problems [message #3103 is a reply to message #3098] Sat, 21 March 2015 19:55 Go to previous messageGo to next message
nux is currently offline  nux
Messages: 1586
Registered: January 2012
Senior Member
Administrator

And btw, I recommend doing updates automatically, there may be issues frequently, better be hands on then have to deal with a broken system later on.
Re: avoid update problems [message #3104 is a reply to message #3102] Sat, 21 March 2015 21:35 Go to previous messageGo to next message
detipco is currently offline  detipco
Messages: 294
Registered: March 2014
Senior Member
nux wrote on Sat, 21 March 2015 20:54
Security only updates do not work on CentOS (yet).
You can add exaile in excludepkgs= in /etc/yum.repos.d/epel.repo



Are you sure, that it works?
Never pinned in repos.

I have pinned exaile in etc/yum.conf:

[main]
exclude=exaile
cachedir=/var/cache/yum/$basearch/$releasever
keepcache=0
debuglevel=2
logfile=/var/log/yum.log
exactarch=1
obsoletes=1
gpgcheck=1
plugins=1
installonly_limit=5
bugtracker_url=http://bugs.centos.org/set_project.php?project_id=23&ref=http://bugs.centos.org/bug_report_page.php?category=yum
distroverpkg=centos-release



[Updated on: Sat, 21 March 2015 21:42]

Report message to a moderator

Re: avoid update problems [message #3105 is a reply to message #3098] Sun, 22 March 2015 18:12 Go to previous messageGo to next message
nux is currently offline  nux
Messages: 1586
Registered: January 2012
Senior Member
Administrator

I think that adding it in yum.conf will work as well, but adding in the EPEL repo will block it only from that repo only; i.e. should I issue any updates, you will receive them. Of course, I will not issue any updates now that it's in EPEL.
Re: avoid update problems [message #3106 is a reply to message #3105] Mon, 23 March 2015 07:22 Go to previous messageGo to next message
detipco is currently offline  detipco
Messages: 294
Registered: March 2014
Senior Member
Tested it, but there will be no effect.
Excluding nux.package in epel.repo or excluding epel.package in epel.repo will not work, don`t know why.
Only the solution in yum.conf works.
I think it`s a problem of the different repos for that package?!
Maybe it`s not good that your packages are updated or upgradet from another repo, only a thought.
Re: avoid update problems [message #3107 is a reply to message #3098] Mon, 23 March 2015 16:58 Go to previous messageGo to next message
nux is currently offline  nux
Messages: 1586
Registered: January 2012
Senior Member
Administrator

It could be a typo. Here's how the beginning of my /etc/yum.repos.d/epel.repo looks like and it does the job ("yum install exaile" will install from nux-dextop, not epel)

[epel]
name=Extra Packages for Enterprise Linux 7 - $basearch
#baseurl=http://download.fedoraproject.org/pub/epel/7/$basearch
mirrorlist=https://mirrors.fedoraproject.org/metalink?repo=epel-7&arch=$basearch
failovermethod=priority
enabled=1
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-EPEL-7
exclude=exaile
Re: avoid update problems [message #3108 is a reply to message #3102] Mon, 23 March 2015 21:40 Go to previous message
detipco is currently offline  detipco
Messages: 294
Registered: March 2014
Senior Member
nux wrote on Sat, 21 March 2015 20:54
Security only updates do not work on CentOS (yet).
You can add exaile in excludepkgs= in /etc/yum.repos.d/epel.repo



Yes of course, because I did it like you wrote in /etc/yum.repos/epel.repo >excludepkgs=exaile< and not like I (and you) did in yum.conf. Very Happy

And btw, for a better overview I will exclude all packages I want in yum.conf.

[Updated on: Mon, 23 March 2015 21:56]

Report message to a moderator

Previous Topic: KORORA and NUX
Next Topic: CentOS 7 1503 x64 (7.1 RH) Released
Goto Forum:
  


Current Time: Fri Feb 23 12:12:40 GMT 2018

Total time taken to generate the page: 0.01215 seconds