Nux!


Home » Stella » Report a problem or request a feature » can't configure mobile broadband (after latest update i'm unable to connect to mobile broadband)
can't configure mobile broadband [message #3121] Thu, 02 April 2015 06:29 Go to next message
mitu is currently offline  mitu
Messages: 85
Registered: February 2012
Location: gurgaon, new delhi, india
Member
From yesterday I'm unable to configure mobile broadband (mts mblaze ultra cdma) on centos 7. The connection just did not show, so I tried to create a new mobile broadband connection. During configuration it detects the carrier and takes the proper values. But after applying ok, it throws an error message:


serial.parity: can't set property of type 'y' from value of type 's'



I'm clueless what went wrong in the latest centos update.
Re: can't configure mobile broadband [message #3124 is a reply to message #3121] Thu, 02 April 2015 10:53 Go to previous messageGo to next message
detipco is currently offline  detipco
Messages: 294
Registered: March 2014
Senior Member
Hi mitu,
don`t know what you can do now, but I think that`s the reason for your problem.

5. Major Changes

    As of March 2015 ABRT (>= 2.1.11-19.el7.centos.0.1) can report bugs directly to bugs.centos.org. You can find information about that feature at this page
    Support for new processors (Intel Broadwell) and graphics (AMD Hawaii)
    Full support for LVM cache
    Ability to mount ceph block devices
    Updated Hyper-V network drivers
    New libguestfs features
    Full support for OpenJDK-1.8.0
    Improved clock stability (for PTP and NTP)
    Updated Networkmanager packages to version 1.0
    Updated docker to 1.4.1
    Updated OpenSSH to 6.6.1
    New package: Mozilla Thunderbird
    Update to numerous storage, network and graphics drivers
    Technology Preview: Support of the Btrfs file system, OverlayFS and the Cisco VIC kernel driver 


Maybe it`s possible to rollback to the last drivers in those old repos.

# CentOS Vault contains rpms from older releases in the CentOS-7 
# tree.

[C7.0.1406-base]
name=CentOS-7.0.1406 - Base
baseurl=http://vault.centos.org/7.0.1406/os/$basearch/
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-7
enabled=0

[C7.0.1406-updates]
name=CentOS-7.0.1406 - Updates
baseurl=http://vault.centos.org/7.0.1406/updates/$basearch/
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-7
enabled=0

[C7.0.1406-extras]
name=CentOS-7.0.1406 - Extras
baseurl=http://vault.centos.org/7.0.1406/extras/$basearch/
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-7
enabled=0

[C7.0.1406-centosplus]
name=CentOS-7.0.1406 - CentOSPlus
baseurl=http://vault.centos.org/7.0.1406/centosplus/$basearch/
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-7
enabled=0

[C7.0.1406-fasttrack]
name=CentOS-7.0.1406 - CentOSPlus
baseurl=http://vault.centos.org/7.0.1406/fasttrack/$basearch/
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-7
enabled=0


Cheers
Re: can't configure mobile broadband [message #3125 is a reply to message #3121] Thu, 02 April 2015 13:09 Go to previous messageGo to next message
nux is currently offline  nux
Messages: 1659
Registered: January 2012
Senior Member
Administrator

Mitu,

I recommend you take this to the CentOS mailing lists or forums, no idea how to help you.
Have you tried booting the old kernel?

Re: can't configure mobile broadband [message #3136 is a reply to message #3125] Sat, 04 April 2015 05:38 Go to previous messageGo to next message
mitu is currently offline  mitu
Messages: 85
Registered: February 2012
Location: gurgaon, new delhi, india
Member
Thanks Nux. I'm booting to elrepo kernel (3.19.3). Downgrading to the earlier version seems worthwhile, but I can't do that on my home pc that's suffering from this mobile broadband problem (I'm posting this from my office workstation). As for taking the issue to Centos forum, I can only laugh, cos very often I've raised some desktop related issues, most of which were not attended. They are a great bunch of people, but seems desktop is not their priority at all.

It would be nice if somebody can list the packages to be downgraded, so that I can download them on office workstation, and then force-install them on my home pc.
[Solved]Re: can't configure mobile broadband [message #3138 is a reply to message #3136] Sun, 05 April 2015 11:30 Go to previous messageGo to next message
mitu is currently offline  mitu
Messages: 85
Registered: February 2012
Location: gurgaon, new delhi, india
Member
Solved. The issue was not related to kernel or other base components. It was the horde of NetworkManager* updates that broke the CDMA MTS Broadband configuration. Only out of sheer guess, I force-removed the NetworkManager packages and then localinstalled just one version older NetworkManager Packages (that I downloaded on my office workstation), and the problem is gone, network manager autoconfigured the mobile broadband for me.

A sigh of relief! But once more, it pains why Centos or RHEL for that matter, pushes messy packages. Certainly desktop is not their priority, may be desktop users are also not fond of centos, that's why none reported such a serious issue.

Here's the transaction details (if any in the third world uses mobile broadband):

Apr 05 14:09:09 Erased: 1:NetworkManager-1.0.0-14.git20150121.b4ea599c.el7.x86_64
Apr 05 14:09:33 Erased: 1:NetworkManager-adsl-1.0.0-14.git20150121.b4ea599c.el7.x86_ 64
Apr 05 14:10:18 Erased: 1:NetworkManager-bluetooth-1.0.0-14.git20150121.b4ea599c.el7 .x86_64
Apr 05 14:10:37 Erased: 1:NetworkManager-wifi-1.0.0-14.git20150121.b4ea599c.el7.x86_ 64
Apr 05 14:14:20 Erased: 1:NetworkManager-wwan-1.0.0-14.git20150121.b4ea599c.el7.x86_ 64
Apr 05 14:14:42 Erased: 1:NetworkManager-team-1.0.0-14.git20150121.b4ea599c.el7.x86_ 64
Apr 05 14:16:00 Erased: 1:NetworkManager-tui-1.0.0-14.git20150121.b4ea599c.el7.x86_6 4
Apr 05 14:16:00 Erased: 1:NetworkManager-libnm-1.0.0-14.git20150121.b4ea599c.el7.x86 _64
Apr 05 15:39:57 Installed: 1:NetworkManager-glib-0.9.9.1-29.git20140326.4dba720.el7_0.x 86_64
Apr 05 15:39:58 Installed: 1:NetworkManager-0.9.9.1-29.git20140326.4dba720.el7_0.x86_64
Apr 05 15:39:58 Installed: 1:NetworkManager-tui-0.9.9.1-29.git20140326.4dba720.el7_0.x8 6_64

Re: [Solved]Re: can't configure mobile broadband [message #3139 is a reply to message #3138] Sun, 05 April 2015 11:57 Go to previous messageGo to next message
detipco is currently offline  detipco
Messages: 294
Registered: March 2014
Senior Member
Hi mitu,
fine that it works now again.
Look to my post, about the networkmanager packages is what I wanted to tell you.
Maybe it was a little mistakable, sorry.
About the messy packages I`m a little peeve too. You are not alone with this pain.

friendly regards Smile
Re: [Solved]Re: can't configure mobile broadband [message #3140 is a reply to message #3139] Sun, 05 April 2015 12:35 Go to previous message
mitu is currently offline  mitu
Messages: 85
Registered: February 2012
Location: gurgaon, new delhi, india
Member
Hi Detipco,

Definitely, guesses don't come just like that, I had read your suggestion and the updated NetworkManager stack that you mentioned must have triggered the guess. Finally, it's all good now. And I'm back using web like before, though on a poor mobile broadband.

Thank you a lot!
Previous Topic: nux build library libXext
Next Topic: how to automount external hard drives
Goto Forum:
  


Current Time: Sun Jul 21 18:10:07 BST 2019

Total time taken to generate the page: 0.01656 seconds