Nux!


Home » Repos » General chat » Audacious dependency issues
Audacious dependency issues [message #3236] Wed, 29 July 2015 14:33 Go to next message
amk is currently offline  amk
Messages: 9
Registered: July 2015
Junior Member
Hello.
First, I really love Nux repo, it makes CentOS7 actually usable on common Joe's desktop. Wink

Just one problem.

Since the update I tried today, audacious-plugins-freeworld can't be updated. More specifically, the audacious-plugins-freeworld-ffaudio package.
I initially installed audacious just with all plugins using the freeworld metapackage and apart from the base plugins I only need mp3 and aac ones, so installing the ffaudio part is not necessary on my end, but still, if anyone needs it, it seems not to work, as it seem to require the older version of libavcodec, libavutil and libavformat. Basically, those present in older ffmpeg 2.3.4, which gets updated to 2.6.3.
error message:
--> Processing Dependency: libavcodec.so.55()(64bit) for package: audacious-plugins-freeworld-ffaudio-3.5-1.el7.nux.x86_64
--> Processing Dependency: libavcodec.so.55(LIBAVCODEC_55)(64bit) for package: audacious-plugins-freeworld-ffaudio-3.5-1.el7.nux.x86_64
--> Processing Dependency: libavformat.so.55()(64bit) for package: audacious-plugins-freeworld-ffaudio-3.5-1.el7.nux.x86_64
--> Processing Dependency: libavformat.so.55(LIBAVFORMAT_55)(64bit) for package: audacious-plugins-freeworld-ffaudio-3.5-1.el7.nux.x86_64
--> Processing Dependency: libavutil.so.52()(64bit) for package: audacious-plugins-freeworld-ffaudio-3.5-1.el7.nux.x86_64
--> Processing Dependency: libavutil.so.52(LIBAVUTIL_52)(64bit) for package: audacious-plugins-freeworld-ffaudio-3.5-1.el7.nux.x86_64
--> Finished Dependency Resolution
Error: Package: audacious-plugins-freeworld-ffaudio-3.5-1.el7.nux.x86_64 (@nux-dextop)
           Requires: libavformat.so.55(LIBAVFORMAT_55)(64bit)
           Removing: ffmpeg-libs-2.3.4-2.el7.nux.x86_64 (@nux-dextop)
               libavformat.so.55(LIBAVFORMAT_55)(64bit)
           Updated By: ffmpeg-libs-2.6.3-1.el7.nux.x86_64 (nux-dextop)
              ~libavformat.so.56(LIBAVFORMAT_56)(64bit)
           Available: ffmpeg-libs-2.2.1-1.el7.nux.x86_64 (nux-dextop)
               libavformat.so.55(LIBAVFORMAT_55)(64bit)
           Available: ffmpeg-libs-2.2.1-2.el7.nux.x86_64 (nux-dextop)
               libavformat.so.55(LIBAVFORMAT_55)(64bit)
           Available: ffmpeg-libs-2.3.2-1.el7.nux.x86_64 (nux-dextop)
               libavformat.so.55(LIBAVFORMAT_55)(64bit)
           Available: ffmpeg-libs-2.3.4-1.el7.nux.x86_64 (nux-dextop)
               libavformat.so.55(LIBAVFORMAT_55)(64bit)
Error: Package: audacious-plugins-freeworld-ffaudio-3.5-1.el7.nux.x86_64 (@nux-dextop)
           Requires: libavcodec.so.55()(64bit)
           Removing: ffmpeg-libs-2.3.4-2.el7.nux.x86_64 (@nux-dextop)
               libavcodec.so.55()(64bit)
           Updated By: ffmpeg-libs-2.6.3-1.el7.nux.x86_64 (nux-dextop)
              ~libavcodec.so.56()(64bit)
           Available: ffmpeg-libs-2.2.1-1.el7.nux.x86_64 (nux-dextop)
               libavcodec.so.55()(64bit)
           Available: ffmpeg-libs-2.2.1-2.el7.nux.x86_64 (nux-dextop)
               libavcodec.so.55()(64bit)
           Available: ffmpeg-libs-2.3.2-1.el7.nux.x86_64 (nux-dextop)
               libavcodec.so.55()(64bit)
           Available: ffmpeg-libs-2.3.4-1.el7.nux.x86_64 (nux-dextop)
               libavcodec.so.55()(64bit)
Error: Package: audacious-plugins-freeworld-ffaudio-3.5-1.el7.nux.x86_64 (@nux-dextop)
           Requires: libavutil.so.52()(64bit)
           Removing: ffmpeg-libs-2.3.4-2.el7.nux.x86_64 (@nux-dextop)
               libavutil.so.52()(64bit)
           Updated By: ffmpeg-libs-2.6.3-1.el7.nux.x86_64 (nux-dextop)
              ~libavutil.so.54()(64bit)
           Available: ffmpeg-libs-2.2.1-1.el7.nux.x86_64 (nux-dextop)
               libavutil.so.52()(64bit)
           Available: ffmpeg-libs-2.2.1-2.el7.nux.x86_64 (nux-dextop)
               libavutil.so.52()(64bit)
           Available: ffmpeg-libs-2.3.2-1.el7.nux.x86_64 (nux-dextop)
               libavutil.so.52()(64bit)
           Available: ffmpeg-libs-2.3.4-1.el7.nux.x86_64 (nux-dextop)
               libavutil.so.52()(64bit)
Error: Package: audacious-plugins-freeworld-ffaudio-3.5-1.el7.nux.x86_64 (@nux-dextop)
           Requires: libavcodec.so.55(LIBAVCODEC_55)(64bit)
           Removing: ffmpeg-libs-2.3.4-2.el7.nux.x86_64 (@nux-dextop)
               libavcodec.so.55(LIBAVCODEC_55)(64bit)
           Updated By: ffmpeg-libs-2.6.3-1.el7.nux.x86_64 (nux-dextop)
              ~libavcodec.so.56(LIBAVCODEC_56)(64bit)
           Available: ffmpeg-libs-2.2.1-1.el7.nux.x86_64 (nux-dextop)
               libavcodec.so.55(LIBAVCODEC_55)(64bit)
           Available: ffmpeg-libs-2.2.1-2.el7.nux.x86_64 (nux-dextop)
               libavcodec.so.55(LIBAVCODEC_55)(64bit)
           Available: ffmpeg-libs-2.3.2-1.el7.nux.x86_64 (nux-dextop)
               libavcodec.so.55(LIBAVCODEC_55)(64bit)
           Available: ffmpeg-libs-2.3.4-1.el7.nux.x86_64 (nux-dextop)
               libavcodec.so.55(LIBAVCODEC_55)(64bit)
Error: Package: audacious-plugins-freeworld-ffaudio-3.5-1.el7.nux.x86_64 (@nux-dextop)
           Requires: libavformat.so.55()(64bit)
           Removing: ffmpeg-libs-2.3.4-2.el7.nux.x86_64 (@nux-dextop)
               libavformat.so.55()(64bit)
           Updated By: ffmpeg-libs-2.6.3-1.el7.nux.x86_64 (nux-dextop)
              ~libavformat.so.56()(64bit)
           Available: ffmpeg-libs-2.2.1-1.el7.nux.x86_64 (nux-dextop)
               libavformat.so.55()(64bit)
           Available: ffmpeg-libs-2.2.1-2.el7.nux.x86_64 (nux-dextop)


Thanks.

[Updated on: Wed, 29 July 2015 17:16]

Report message to a moderator

Re: Audacious dependency issues [message #3237 is a reply to message #3236] Wed, 29 July 2015 21:51 Go to previous messageGo to next message
nux is currently offline  nux
Messages: 1521
Registered: January 2012
Senior Member
Administrator

Thanks for reporting! I'll try to fix this shortly.
Re: Audacious dependency issues [message #3238 is a reply to message #3236] Wed, 29 July 2015 22:09 Go to previous messageGo to next message
nux is currently offline  nux
Messages: 1521
Registered: January 2012
Senior Member
Administrator

I've issued updated packages that should fix this issue, let me know if you hit any further problems.
Re: Audacious dependency issues [message #3244 is a reply to message #3236] Thu, 30 July 2015 12:21 Go to previous messageGo to next message
Maloon
Messages: 3
Registered: July 2015
Junior Member
minidlna doesn't work with update:

--> Ejecutando prueba de transacción
---> Paquete ffmpeg-compat.x86_64 0:0.6.7-6.el7.nux debe ser actualizado
---> Paquete ffmpeg-compat.x86_64 0:0.6.7-9.el7.nux debe ser una actualización
--> Procesando dependencias: libjack.so.0()(64bit) para el paquete: ffmpeg-compat-0.6.7-9.el7.nux.x86_64
---> Paquete ffmpeg-libs.x86_64 0:2.3.4-2.el7.nux debe ser actualizado
--> Procesando dependencias: libavformat.so.55()(64bit) para el paquete: minidlna-1.1.4-3.el7.nux.x86_64
--> Procesando dependencias: libavformat.so.55(LIBAVFORMAT_55)(64bit) para el paquete: minidlna-1.1.4-3.el7.nux.x86_64
--> Procesando dependencias: libavutil.so.52()(64bit) para el paquete: minidlna-1.1.4-3.el7.nux.x86_64
--> Procesando dependencias: libavutil.so.52(LIBAVUTIL_52)(64bit) para el paquete: minidlna-1.1.4-3.el7.nux.x86_64
---> Paquete ffmpeg-libs.x86_64 0:2.6.3-1.el7.nux debe ser una actualización
--> Procesando dependencias: libx265.so.51()(64bit) para el paquete: ffmpeg-libs-2.6.3-1.el7.nux.x86_64
---> Paquete libquicktime.x86_64 0:1.2.4-16.el7.nux debe ser actualizado
---> Paquete libquicktime.x86_64 0:1.2.4-19.el7.nux debe ser una actualización
---> Paquete vlc.x86_64 0:2.1.5-2.el7.nux debe ser actualizado
---> Paquete vlc.x86_64 0:2.2.1-6.el7.nux debe ser una actualización
---> Paquete vlc-core.x86_64 0:2.1.5-2.el7.nux debe ser actualizado
---> Paquete vlc-core.x86_64 0:2.2.1-6.el7.nux debe ser una actualización
---> Paquete x264-libs.x86_64 0:0.142-7.20140728gitaf8e768.el7.nux debe ser actualizado
---> Paquete x264-libs.x86_64 0:0.142-11.20141221git6a301b6.el7.nux debe ser una actualización
--> Ejecutando prueba de transacción
---> Paquete ffmpeg-libs.x86_64 0:2.3.4-2.el7.nux debe ser actualizado
--> Procesando dependencias: libavformat.so.55()(64bit) para el paquete: minidlna-1.1.4-3.el7.nux.x86_64
--> Procesando dependencias: libavformat.so.55(LIBAVFORMAT_55)(64bit) para el paquete: minidlna-1.1.4-3.el7.nux.x86_64
--> Procesando dependencias: libavutil.so.52()(64bit) para el paquete: minidlna-1.1.4-3.el7.nux.x86_64
--> Procesando dependencias: libavutil.so.52(LIBAVUTIL_52)(64bit) para el paquete: minidlna-1.1.4-3.el7.nux.x86_64
---> Paquete jack-audio-connection-kit.x86_64 0:1.9.9.5-4.el7 debe ser instalado
--> Procesando dependencias: libffado.so.2()(64bit) para el paquete: jack-audio-connection-kit-1.9.9.5-4.el7.x86_64
---> Paquete x265-libs.x86_64 0:1.6-1.el7.nux debe ser instalado
--> Ejecutando prueba de transacción
---> Paquete ffmpeg-libs.x86_64 0:2.3.4-2.el7.nux debe ser actualizado
--> Procesando dependencias: libavformat.so.55()(64bit) para el paquete: minidlna-1.1.4-3.el7.nux.x86_64
--> Procesando dependencias: libavformat.so.55(LIBAVFORMAT_55)(64bit) para el paquete: minidlna-1.1.4-3.el7.nux.x86_64
--> Procesando dependencias: libavutil.so.52()(64bit) para el paquete: minidlna-1.1.4-3.el7.nux.x86_64
--> Procesando dependencias: libavutil.so.52(LIBAVUTIL_52)(64bit) para el paquete: minidlna-1.1.4-3.el7.nux.x86_64
---> Paquete libffado.x86_64 0:2.1.0-4.el7 debe ser instalado
--> Procesando dependencias: libxml++-2.6.so.2()(64bit) para el paquete: libffado-2.1.0-4.el7.x86_64
--> Ejecutando prueba de transacción
---> Paquete ffmpeg-libs.x86_64 0:2.3.4-2.el7.nux debe ser actualizado
--> Procesando dependencias: libavformat.so.55()(64bit) para el paquete: minidlna-1.1.4-3.el7.nux.x86_64
--> Procesando dependencias: libavformat.so.55(LIBAVFORMAT_55)(64bit) para el paquete: minidlna-1.1.4-3.el7.nux.x86_64
--> Procesando dependencias: libavutil.so.52()(64bit) para el paquete: minidlna-1.1.4-3.el7.nux.x86_64
--> Procesando dependencias: libavutil.so.52(LIBAVUTIL_52)(64bit) para el paquete: minidlna-1.1.4-3.el7.nux.x86_64
---> Paquete libxml++.x86_64 0:2.37.1-1.el7 debe ser instalado
--> Resolución de dependencias finalizada
Error: Paquete: minidlna-1.1.4-3.el7.nux.x86_64 (@nux-dextop)
           Necesita: libavutil.so.52(LIBAVUTIL_52)(64bit)
           Eliminando: ffmpeg-libs-2.3.4-2.el7.nux.x86_64 (@nux-dextop)
               libavutil.so.52(LIBAVUTIL_52)(64bit)
           Actualizado por: ffmpeg-libs-2.6.3-1.el7.nux.x86_64 (nux-dextop)
              ~libavutil.so.54(LIBAVUTIL_54)(64bit)
           Disponible: ffmpeg-libs-2.2.1-1.el7.nux.x86_64 (nux-dextop)
               libavutil.so.52(LIBAVUTIL_52)(64bit)
           Disponible: ffmpeg-libs-2.2.1-2.el7.nux.x86_64 (nux-dextop)
               libavutil.so.52(LIBAVUTIL_52)(64bit)
           Disponible: ffmpeg-libs-2.3.2-1.el7.nux.x86_64 (nux-dextop)
               libavutil.so.52(LIBAVUTIL_52)(64bit)
           Disponible: ffmpeg-libs-2.3.4-1.el7.nux.x86_64 (nux-dextop)
               libavutil.so.52(LIBAVUTIL_52)(64bit)
Error: Paquete: minidlna-1.1.4-3.el7.nux.x86_64 (@nux-dextop)
           Necesita: libavutil.so.52()(64bit)
           Eliminando: ffmpeg-libs-2.3.4-2.el7.nux.x86_64 (@nux-dextop)
               libavutil.so.52()(64bit)
           Actualizado por: ffmpeg-libs-2.6.3-1.el7.nux.x86_64 (nux-dextop)
              ~libavutil.so.54()(64bit)
           Disponible: ffmpeg-libs-2.2.1-1.el7.nux.x86_64 (nux-dextop)
               libavutil.so.52()(64bit)
           Disponible: ffmpeg-libs-2.2.1-2.el7.nux.x86_64 (nux-dextop)
               libavutil.so.52()(64bit)
           Disponible: ffmpeg-libs-2.3.2-1.el7.nux.x86_64 (nux-dextop)
               libavutil.so.52()(64bit)
           Disponible: ffmpeg-libs-2.3.4-1.el7.nux.x86_64 (nux-dextop)
               libavutil.so.52()(64bit)
Error: Paquete: minidlna-1.1.4-3.el7.nux.x86_64 (@nux-dextop)
           Necesita: libavformat.so.55()(64bit)
           Eliminando: ffmpeg-libs-2.3.4-2.el7.nux.x86_64 (@nux-dextop)
               libavformat.so.55()(64bit)
           Actualizado por: ffmpeg-libs-2.6.3-1.el7.nux.x86_64 (nux-dextop)
              ~libavformat.so.56()(64bit)
           Disponible: ffmpeg-libs-2.2.1-1.el7.nux.x86_64 (nux-dextop)
               libavformat.so.55()(64bit)
           Disponible: ffmpeg-libs-2.2.1-2.el7.nux.x86_64 (nux-dextop)
               libavformat.so.55()(64bit)
           Disponible: ffmpeg-libs-2.3.2-1.el7.nux.x86_64 (nux-dextop)
               libavformat.so.55()(64bit)
           Disponible: ffmpeg-libs-2.3.4-1.el7.nux.x86_64 (nux-dextop)
               libavformat.so.55()(64bit)
Error: Paquete: minidlna-1.1.4-3.el7.nux.x86_64 (@nux-dextop)
           Necesita: libavformat.so.55(LIBAVFORMAT_55)(64bit)
           Eliminando: ffmpeg-libs-2.3.4-2.el7.nux.x86_64 (@nux-dextop)
               libavformat.so.55(LIBAVFORMAT_55)(64bit)
           Actualizado por: ffmpeg-libs-2.6.3-1.el7.nux.x86_64 (nux-dextop)
              ~libavformat.so.56(LIBAVFORMAT_56)(64bit)
           Disponible: ffmpeg-libs-2.2.1-1.el7.nux.x86_64 (nux-dextop)
               libavformat.so.55(LIBAVFORMAT_55)(64bit)
           Disponible: ffmpeg-libs-2.2.1-2.el7.nux.x86_64 (nux-dextop)
               libavformat.so.55(LIBAVFORMAT_55)(64bit)
           Disponible: ffmpeg-libs-2.3.2-1.el7.nux.x86_64 (nux-dextop)
               libavformat.so.55(LIBAVFORMAT_55)(64bit)
           Disponible: ffmpeg-libs-2.3.4-1.el7.nux.x86_64 (nux-dextop)
               libavformat.so.55(LIBAVFORMAT_55)(64bit)
 Podría intentar utilizar el comando --skip-broken para sortear el problema
Podría intentar ejecutar: rpm- Va --nofiles --nodigest

Re: Audacious dependency issues [message #3245 is a reply to message #3238] Thu, 30 July 2015 16:24 Go to previous messageGo to next message
amk is currently offline  amk
Messages: 9
Registered: July 2015
Junior Member
Thanks, it's working fine now. That was quite quick!

I don't have so much installed from your repo, as my needs are not so high, but should I encounter any problem I'll surely let you know. Wink
Mplayer is a must and vlc is good as a fallback, should mplayer have a problem with some video. Plus libdvdcss and gstreamer plugins for FF and web videos (I don't use flash at all). Handbrake is quite cool for simple re-encodes and dvd ripping.
I have MakeMKV license that I use primarily for BD rips, but even though it can do DVD ripping, HandBrake will do them including encoding.
So it's great to have that available.

Thanks again for the quick fix. Smile

[Updated on: Thu, 30 July 2015 16:26]

Report message to a moderator

Re: Audacious dependency issues [message #3251 is a reply to message #3236] Fri, 31 July 2015 08:53 Go to previous message
nux is currently offline  nux
Messages: 1521
Registered: January 2012
Senior Member
Administrator

Glad it helped you.
I've also rebuilt minidlna.
Previous Topic: MythTV
Next Topic: VIVALDI TP4
Goto Forum:
  


Current Time: Tue Apr 25 23:15:16 BST 2017

Total time taken to generate the page: 0.00602 seconds