Nux!


Home » Stella » Report a problem or request a feature » Updating VLC after holding to previous version for a while
Updating VLC after holding to previous version for a while [message #3705] Wed, 05 October 2016 08:32 Go to next message
accessgranted is currently offline  accessgranted
Messages: 38
Registered: December 2015
Member
Hi, I decided some time ago to stick wint an older version of VLC and libdvdread because they gave better results reading dvd's on my CentOS7 machine. I now would like to see if more recent versions of VLC are better at reading dvd's than they were previously. So I ran yumex, but the process resulted in this series of errors:
09:16:55 : ERROR - ERROR: Dependency resolving completed with errors
09:16:55 : ERROR - ERROR: Package: 1:vlc-core-2.2.2-5.el7.nux.x86_64 (nux-dextop)
Requires: libgroupsock.so.1()(64bit)
Removing: live555-2013.11.26-1.el7.nux.x86_64 (@nux-dextop)
libgroupsock.so.1()(64bit)
Updated By: live555-2016.03.14-2.el7.nux.x86_64 (li.nux.ro_download_nux_tmp_vlc7_)
Not found
09:16:55 : ERROR - ERROR: Package: 1:vlc-core-2.2.2-5.el7.nux.x86_64 (nux-dextop)
Requires: libBasicUsageEnvironment.so.0()(64bit)
Removing: live555-2013.11.26-1.el7.nux.x86_64 (@nux-dextop)
libBasicUsageEnvironment.so.0()(64bit)
Updated By: live555-2016.03.14-2.el7.nux.x86_64 (li.nux.ro_download_nux_tmp_vlc7_)
Not found
09:16:55 : ERROR - ERROR: Package: 1:vlc-core-2.2.2-5.el7.nux.x86_64 (nux-dextop)
Requires: libBasicUsageEnvironment.so.0()(64bit)
Removing: live555-2013.11.26-1.el7.nux.x86_64 (@nux-dextop)
libBasicUsageEnvironment.so.0()(64bit)
Updated By: live555-2016.03.14-2.el7.nux.x86_64 (li.nux.ro_download_nux_tmp_vlc7_)
Not found
Obsoleted By: live555-libs-2016.03.14-2.el7.nux.x86_64 (li.nux.ro_download_nux_tmp_vlc7_)
~libBasicUsageEnvironment.so.1()(64bit)
09:16:55 : ERROR - ERROR: Package: 1:vlc-core-2.2.2-5.el7.nux.x86_64 (li.nux.ro_download_nux_tmp_vlc7_)
Requires: libdvbpsi.so.7()(64bit)
Removing: libdvbpsi-0.2.2-3.el7.nux.x86_64 (@nux-dextop)
libdvbpsi.so.7()(64bit)
Updated By: libdvbpsi-1.3.0-2.el7.nux.x86_64 (nux-dextop)
~libdvbpsi.so.10()(64bit)
09:16:55 : ERROR - ERROR: Package: 1:vlc-core-2.2.2-5.el7.nux.x86_64 (nux-dextop)
Requires: libliveMedia.so.17()(64bit)
Removing: live555-2013.11.26-1.el7.nux.x86_64 (@nux-dextop)
libliveMedia.so.17()(64bit)
Updated By: live555-2016.03.14-2.el7.nux.x86_64 (li.nux.ro_download_nux_tmp_vlc7_)
Not found
09:16:55 : ERROR - ERROR: Package: 1:vlc-core-2.2.2-5.el7.nux.x86_64 (nux-dextop)
Requires: libUsageEnvironment.so.1()(64bit)
Removing: live555-2013.11.26-1.el7.nux.x86_64 (@nux-dextop)
libUsageEnvironment.so.1()(64bit)
Updated By: live555-2016.03.14-2.el7.nux.x86_64 (li.nux.ro_download_nux_tmp_vlc7_)
Not found
Obsoleted By: live555-libs-2016.03.14-2.el7.nux.x86_64 (li.nux.ro_download_nux_tmp_vlc7_)
~libUsageEnvironment.so.3()(64bit)
09:16:55 : ERROR - ERROR: Package: 1:vlc-core-2.2.2-5.el7.nux.x86_64 (nux-dextop)
Requires: libliveMedia.so.17()(64bit)
Removing: live555-2013.11.26-1.el7.nux.x86_64 (@nux-dextop)
libliveMedia.so.17()(64bit)
Updated By: live555-2016.03.14-2.el7.nux.x86_64 (li.nux.ro_download_nux_tmp_vlc7_)
Not found
Obsoleted By: live555-libs-2016.03.14-2.el7.nux.x86_64 (li.nux.ro_download_nux_tmp_vlc7_)
~libliveMedia.so.52()(64bit)
09:16:55 : ERROR - ERROR: Package: 1:vlc-core-2.2.2-5.el7.nux.x86_64 (nux-dextop)
Requires: libUsageEnvironment.so.1()(64bit)
Removing: live555-2013.11.26-1.el7.nux.x86_64 (@nux-dextop)
libUsageEnvironment.so.1()(64bit)
Updated By: live555-2016.03.14-2.el7.nux.x86_64 (li.nux.ro_download_nux_tmp_vlc7_)
Not found
09:16:55 : ERROR - ERROR: Package: 1:vlc-core-2.2.2-5.el7.nux.x86_64 (nux-dextop)
Requires: libgroupsock.so.1()(64bit)
Removing: live555-2013.11.26-1.el7.nux.x86_64 (@nux-dextop)
libgroupsock.so.1()(64bit)
Updated By: live555-2016.03.14-2.el7.nux.x86_64 (li.nux.ro_download_nux_tmp_vlc7_)
Not found
Obsoleted By: live555-libs-2016.03.14-2.el7.nux.x86_64 (li.nux.ro_download_nux_tmp_vlc7_)
~libgroupsock.so.8()(64bit)

Can't find libgroupsock or libdvbpsi anywhere in the repos. Any suggestion how to clean up the mess?
Thanks
Re: Updating VLC after holding to previous version for a while [message #3706 is a reply to message #3705] Wed, 05 October 2016 19:56 Go to previous messageGo to next message
accessgranted is currently offline  accessgranted
Messages: 38
Registered: December 2015
Member
Ok, after some thought, at first I did this:
sudo yum remove vlc vlc-core

Then I deleted li.nux.ro/download/nux/tmp/vlc7 from the yum.repos.d folder

Then I removed exclude=vlc vlc-core libdvdread libbluray live555 live555-libs libdvbpsi from the yum.conf file

I finally did this: sudo yum install vlc vlc-core

That would seem to do the trick!? Next I will try and see if DVD's are correctly played by these new versions.

Cheers

Re: Updating VLC after holding to previous version for a while [message #3707 is a reply to message #3706] Wed, 05 October 2016 21:48 Go to previous messageGo to next message
accessgranted is currently offline  accessgranted
Messages: 38
Registered: December 2015
Member
Back to square one with absent dvd menus Sad So I'll get back to the li.nux.ro/download/nux/tmp/vlc7 tactics.
Re: Updating VLC after holding to previous version for a while [message #3708 is a reply to message #3707] Wed, 05 October 2016 22:02 Go to previous messageGo to next message
amk is currently offline  amk
Messages: 9
Registered: July 2015
Junior Member
I keep VLC just in case, but I practically all the time use mplayer (1.3 from source) as it simply provides more compatibility with most media. Plus, I'm just an mplayer snob. Wink
Anyway, DVD playback is pain in mplayer sometimes too, depends on the DVD, but I found out, that by far the most consistent DVD playback comes from Kodi.
So I use Kodi just for DVD playback, not a single problem since.
Re: Updating VLC after holding to previous version for a while [message #3710 is a reply to message #3705] Fri, 07 October 2016 10:05 Go to previous messageGo to next message
nux is currently offline  nux
Messages: 1658
Registered: January 2012
Senior Member
Administrator

I'll update the VLC in the tmp repo to match new stuff. Make sure you also do a "yum clean all" before upgrading to it - if at all.
Re: Updating VLC after holding to previous version for a while [message #3711 is a reply to message #3705] Fri, 07 October 2016 10:37 Go to previous messageGo to next message
nux is currently offline  nux
Messages: 1658
Registered: January 2012
Senior Member
Administrator

I've updated the VLC packages in http://li.nux.ro/download/nux/tmp/vlc7/
Feel free to give them a try and let me know if you hit any issues.
Re: Updating VLC after holding to previous version for a while [message #3712 is a reply to message #3705] Fri, 07 October 2016 18:51 Go to previous messageGo to next message
accessgranted is currently offline  accessgranted
Messages: 38
Registered: December 2015
Member
Still looks like a complete mess on my system:

Dependency Resolution Errors:

Package: 1:vlc-core-2.2.2-6.el7.nux.x86_64 (li.nux.ro_download_nux_tmp_vlc7_)
Requires: libBasicUsageEnvironment.so.0()(64bit)
Removing: live555-2013.11.26-1.el7.nux.x86_64 (@nux-dextop)
libBasicUsageEnvironment.so.0()(64bit)
Obsoleted By: live555-libs-2016.03.14-2.el7.nux.x86_64 (li.nux.ro_download_nux_tmp_vlc7_)
~libBasicUsageEnvironment.so.1()(64bit)Package: 1:vlc-core-2.2.2-6.el7.nux.x86_64 (li.nux.ro_download_nux_tmp_vlc7_)
Requires: libliveMedia.so.17()(64bit)
Removing: live555-2013.11.26-1.el7.nux.x86_64 (@nux-dextop)
libliveMedia.so.17()(64bit)
Obsoleted By: live555-libs-2016.03.14-2.el7.nux.x86_64 (li.nux.ro_download_nux_tmp_vlc7_)
~libliveMedia.so.52()(64bit)Package: 1:vlc-core-2.2.2-6.el7.nux.x86_64 (li.nux.ro_download_nux_tmp_vlc7_)
Requires: libgroupsock.so.1()(64bit)
Removing: live555-2013.11.26-1.el7.nux.x86_64 (@nux-dextop)
libgroupsock.so.1()(64bit)
Obsoleted By: live555-libs-2016.03.14-2.el7.nux.x86_64 (li.nux.ro_download_nux_tmp_vlc7_)
~libgroupsock.so.8()(64bit)Package: 1:vlc-core-2.2.2-6.el7.nux.x86_64 (li.nux.ro_download_nux_tmp_vlc7_)
Requires: libUsageEnvironment.so.1()(64bit)
Removing: live555-2013.11.26-1.el7.nux.x86_64 (@nux-dextop)
libUsageEnvironment.so.1()(64bit)
Obsoleted By: live555-libs-2016.03.14-2.el7.nux.x86_64 (li.nux.ro_download_nux_tmp_vlc7_)
~libUsageEnvironment.so.3()(64bit)
Re: Updating VLC after holding to previous version for a while [message #3713 is a reply to message #3705] Sat, 08 October 2016 11:09 Go to previous messageGo to next message
nux is currently offline  nux
Messages: 1658
Registered: January 2012
Senior Member
Administrator

I'll give this a try on Monday and see what can be done.
Re: Updating VLC after holding to previous version for a while [message #3714 is a reply to message #3705] Mon, 10 October 2016 13:33 Go to previous messageGo to next message
nux is currently offline  nux
Messages: 1658
Registered: January 2012
Senior Member
Administrator

I've fixed the repo, but it might also be a good idea to check VLC AppImage from here:
https://bintray.com/probono/AppImages/VLC#files

Hopefully they can play DVDs just fine.
Re: Updating VLC after holding to previous version for a while [message #3715 is a reply to message #3714] Mon, 10 October 2016 19:28 Go to previous messageGo to next message
accessgranted is currently offline  accessgranted
Messages: 38
Registered: December 2015
Member
Hi Nux, I must admit you're kind of a magician! The update now works flawlessly, as illustrated.
Re: Updating VLC after holding to previous version for a while [message #3716 is a reply to message #3715] Mon, 10 October 2016 19:34 Go to previous messageGo to next message
accessgranted is currently offline  accessgranted
Messages: 38
Registered: December 2015
Member
VLC now was updated to 222 Weatherwax. Getting VLC to read dvd's still doesn't work: opening with menus simply stops VLC. Opening with ticked ''No Disk Menu'' box does open the dvd, but no navigation is possible, i.e.one can't skip to the next chapter or next episode and VLC stops again when trying. Think I will have to stick with the old version of VLC a bit more. Thanks for your efforts though. Much obliged.
Re: Updating VLC after holding to previous version for a while [message #3717 is a reply to message #3716] Mon, 10 October 2016 22:55 Go to previous messageGo to next message
accessgranted is currently offline  accessgranted
Messages: 38
Registered: December 2015
Member
Funnily, reading an .iso image of a given DVD is no problem at all with the updated VLC 2.2.2. Menus run fine, everything works perfectly. But accessing the very same content's menus directly from a DVD won't do. Strange.
Re: Updating VLC after holding to previous version for a while [message #3721 is a reply to message #3705] Tue, 11 October 2016 09:14 Go to previous message
nux is currently offline  nux
Messages: 1658
Registered: January 2012
Senior Member
Administrator

I'm at a loss with regards to this at the moment, especially as I can't test.

Can you give the AppImage a try and see if that works with the iso and with the dvd?
Previous Topic: Please update gstreamer1 for EL7
Next Topic: Error in jmtpfs udev rules
Goto Forum:
  


Current Time: Thu May 23 02:04:25 BST 2019

Total time taken to generate the page: 0.03929 seconds