Nux!


Home » Stella » Report a problem or request a feature » kodi-pvr-iptvsimple-14.0 - incompatible API version (kodi-pvr-iptvsimple-14.0-0.2.20150125gita0a437e.el7.nux.x86_64 doesn't work with kodi-16.1-1.el7.nux.x86_64)
kodi-pvr-iptvsimple-14.0 - incompatible API version [message #3865] Sun, 18 June 2017 18:52 Go to next message
milanm
Messages: 4
Registered: June 2017
Junior Member
Hi everyone,

I installed main Kodi binary from kodi-16.1-1.el7.nux.x86_64 RPM package.

I then tried to install Simple IPTV client from here: kodi-pvr-iptvsimple-14.0-0.2.20150125gita0a437e.el7.nux.x86_ 64

Upon startup of Kodi, I get notification that PVR client cannot be loaded and I see this string in the kodi.log:

ERROR: PVR - Add-on 'PVR IPTV Simple Client' is using an incompatible API version. XBMC minimum API version = '4.1.0', add-on API version '1.9.2'




Nux, looking for this string on the internet, it appears that IPTV simple client needs to be recompiled?
Or, if someone managed to get this to work, can you please share how?


Many thanks in advance.

Re: kodi-pvr-iptvsimple-14.0 - incompatible API version [message #3866 is a reply to message #3865] Mon, 19 June 2017 09:45 Go to previous messageGo to next message
nux is currently offline  nux
Messages: 1662
Registered: January 2012
Senior Member
Administrator

I've updated the repo at http://li.nux.ro/download/nux/tmp/kodi7/

Can you try to install http://li.nux.ro/download/nux/tmp/kodi7/kodi-pvr-iptvsimple- 1.12.14-1.el7.nux.x86_64.rpm ?
Re: kodi-pvr-iptvsimple-14.0 - incompatible API version [message #3867 is a reply to message #3866] Tue, 20 June 2017 02:22 Go to previous messageGo to next message
milanm
Messages: 4
Registered: June 2017
Junior Member
Many thanks, amigo -- the issue has been resolved.

I can confirm that simple iptv client now works.

You rock!

Re: kodi-pvr-iptvsimple-14.0 - incompatible API version [message #3868 is a reply to message #3865] Tue, 20 June 2017 13:59 Go to previous messageGo to next message
nux is currently offline  nux
Messages: 1662
Registered: January 2012
Senior Member
Administrator

Thanks for testing. Can you confirm whether you use any other kodi-pvr-addon packages?
I think they all might be incompatible and require removing.
Re: kodi-pvr-iptvsimple-14.0 - incompatible API version [message #3869 is a reply to message #3868] Tue, 20 June 2017 20:53 Go to previous messageGo to next message
milanm
Messages: 4
Registered: June 2017
Junior Member
I will do so. I will test once I get home tonight. I'll install all the PVR clients and enable them all.

I don't have accounts on any of them (e.g. Argus TV), but I think that I can leave account settings blank. It should be enough to just enable them and restart kodi and monitor for errors in logs.

Will let you know what I find.

Re: kodi-pvr-iptvsimple-14.0 - incompatible API version [message #3870 is a reply to message #3869] Wed, 21 June 2017 14:22 Go to previous message
milanm
Messages: 4
Registered: June 2017
Junior Member
Hi, sorry for late reply, had a few things on the go. Here are the results.

The following RPMs all failed to work:

kodi-pvr-argustv
kodi-pvr-demo
kodi-pvr-dvblink
kodi-pvr-mediaportal-tvserver
kodi-pvr-nextpvr
kodi-pvr-filmon
kodi-pvr-hts
kodi-pvr-vuplus

Interesting thing is that they *all* failed with the same message: API level required is 4.1.0 and they all offer 1.9.2. This was the same message as Simple IPTV client failure. Likely this happened because they rely on the same underlying libraries.



The rest of RPMs did not result in any errors in the kodi.log. These are:

kodi-pvr-iptvsimple-debuginfo-1.12.14-1.el7.nux.x86_64
kodi-pvr-vdr-vnsi-14.0-0.2.20150125gita0a437e.el7.nux.x86_64
kodi-pvr-addons-debuginfo-14.0-0.2.20150125gita0a437e.el7.nu x.x86_64
kodi-pvr-addons-common-14.0-0.2.20150125gita0a437e.el7.nux.n oarch
kodi-pvr-mythtv-14.0-0.2.20150125gita0a437e.el7.nux.x86_64
kodi-pvr-dvbviewer-14.0-0.2.20150125gita0a437e.el7.nux.x86_6 4
kodi-pvr-njoy-14.0-0.2.20150125gita0a437e.el7.nux.x86_64
kodi-pvr-wmc-14.0-0.2.20150125gita0a437e.el7.nux.x86_64
kodi-pvr-iptvsimple-1.12.14-1.el7.nux.x86_64

(You'll notice that we have kodi-pvr-dvblink in the group that failed, but we have kodi-pvr-dvbviewer in the group that did not fail. No idea why.)

Hope this helps.
Previous Topic: Google Chrome - Something went wrong when opening your profile
Next Topic: Audacious dependency issues between Nux and EPEL repos
Goto Forum:
  


Current Time: Sun Dec 15 13:29:17 GMT 2019

Total time taken to generate the page: 0.01271 seconds