Nux!


Home » Stella » Report a problem or request a feature » Problem accesing Forum (Security alert)
Problem accesing Forum [message #365] Sun, 12 August 2012 21:56 Go to next message
kc1di is currently offline  kc1di
Messages: 4
Registered: August 2012
Junior Member
Wasn't sure where this should be posted, but every time I try to come to the forum I get a certificate not accepted
alert and have to do a security exception to get here. Is there some way to avoid this?

& why is this happening?
thanks

Re: Problem accesing Forum [message #366 is a reply to message #365] Sun, 12 August 2012 23:45 Go to previous messageGo to next message
nux is currently offline  nux
Messages: 1659
Registered: January 2012
Senior Member
Administrator

Hi and thanks for reporting.

Once you accept the SSL exception all should be good; I'm using a self signed cert, hence the error.

If you are getting it every time you're visiting, can you please send me more details about it? Maybe some screenshots as well.
Which browser are you using?

Re: Problem accesing Forum [message #367 is a reply to message #366] Mon, 13 August 2012 00:49 Go to previous messageGo to next message
kc1di is currently offline  kc1di
Messages: 4
Registered: August 2012
Junior Member
thanks for the quick reply , I found that I'm not getting it on one machine.
The one I'm using Chromium-Browser on seem to be ok for awhile then askes again.
but let me test it a few day see what happens.
Dave
Re: Problem accesing Forum (Solved) [message #368 is a reply to message #367] Mon, 13 August 2012 11:53 Go to previous messageGo to next message
kc1di is currently offline  kc1di
Messages: 4
Registered: August 2012
Junior Member
I've switched to Chrome , which should be the same as Chromium and no longer get the message every time
So guess it's solved for now.
Thanks,
Dave Smile
Re: Problem accesing Forum [message #370 is a reply to message #365] Tue, 14 August 2012 07:10 Go to previous messageGo to next message
nux is currently offline  nux
Messages: 1659
Registered: January 2012
Senior Member
Administrator

great, thanks for the feedback.
Re: Problem accesing Forum [message #1077 is a reply to message #365] Mon, 11 March 2013 01:51 Go to previous messageGo to next message
cb474 is currently offline  cb474
Messages: 4
Registered: March 2013
Junior Member
I also got the certificate warning, coming to the forums both through Firefox and Chromium.

With all do respect, isn't this a bit of a PR problem for this distro? Self-signed certificates, as far as I understand (I'm a lay person, not a developer), are more vulnerable to man-in-the-middle attacks. This, I guess, can be solved by providing a root certificate to users or letting them verify the certificate with hashes, which doesn't appear to be an option here, is it?

In any case, I imagine anyone interested in a desktop friendly spin of Cent OS, may have a particulare interest in stability and security. Being greeted with the certificate warning when you arrive at the forum not only makes people potentially feel uneasy about creating an account at the forum, but also with using the Stella distro itself.

I my own experience, I pretty much never come across a website that has a certificate warning that's not in some way less than the most upstanding business. I've never experienced it with a forum before. Maybe it's worth it to just do the certificate the usual way (through a certificate authority)? Or provide the extra steps for people to verify the certificate from the forum to demonstrate your concern about security?

Just some suggestions as a potential new user of Stella.

[Updated on: Mon, 11 March 2013 01:54]

Report message to a moderator

Re: Problem accesing Forum [message #1080 is a reply to message #365] Mon, 11 March 2013 07:27 Go to previous messageGo to next message
nux is currently offline  nux
Messages: 1659
Registered: January 2012
Senior Member
Administrator

Thanks for the warning.
Regarding the PR issue, it's not something I really care too much, really, but you do have a point with the security weakness. I should either provide the CA or get a proper one in place (which I might just do eventually).
Re: Problem accesing Forum [message #1085 is a reply to message #365] Mon, 11 March 2013 23:57 Go to previous messageGo to next message
cb474 is currently offline  cb474
Messages: 4
Registered: March 2013
Junior Member
Thanks. Yeah, it would be nice for us nerdy folk who are concerned about such things to have a way to verify the the certificate, whether or not through a traditional certificate authority.
Re: Problem accesing Forum [message #1090 is a reply to message #365] Wed, 13 March 2013 11:13 Go to previous message
nux is currently offline  nux
Messages: 1659
Registered: January 2012
Senior Member
Administrator

I've replaced the self-signed SSL cert with one issued by StartSSL.
Previous Topic: Bluecurve Icon / Cursor Theme broken
Next Topic: Infinality fonts
Goto Forum:
  


Current Time: Thu Sep 19 00:02:20 BST 2019

Total time taken to generate the page: 0.05956 seconds