Nux!


Home » Stella » Report a problem or request a feature » xorg server crashes on video playback in stella 6.3 i386 (xorg server crashes on video playback in stella 6.3 i386)
xorg server crashes on video playback in stella 6.3 i386 [message #442] Tue, 02 October 2012 20:14 Go to next message
Haker Defo is currently offline  Haker Defo
Messages: 30
Registered: October 2012
Location: India
Member

Hello Nux! Kudos for making a great centos remix! For the last few months i've been thinking about migrating to linux from windows and i've been doing some 'research' on chosing a good distro for me and my search took me to stella. I've downloaded the 32 bit version and have been testing it on my machine using live dvd, infact i'm posting this entry using firefox in stella. stella is fast, light and responsive. Every thing is working fine except video playback. I tried playing an avi video in totem and xorg crashed and i was taken back to live log in screen. The same thing happened while playing an mp4 video. I installed sm player and vlc and the same xorg crash occured with them too. My pc specs are amd sempron processor, gigabyte motherboard GA-K8M800M with via K8M800 and via VT8237R chipsets and 2 gb DDR ram. I've tested Solusos eveline, Antix Linux 12, Mepis, Xubuntu in live mode and videos played fine with them. I've never had any video playback issues in windows XP. Now to the point, i am really impressed with Stella 6.3 and would love to install it on my pc but i can't live without the ability to play videos. Please please help me! P.S. i think my chipset is using openchrome driver.

[Updated on: Tue, 02 October 2012 20:18]

Report message to a moderator

Re: xorg server crashes on video playback in stella 6.3 i386 [message #443 is a reply to message #442] Tue, 02 October 2012 22:41 Go to previous messageGo to next message
nux is currently offline  nux
Messages: 1659
Registered: January 2012
Senior Member
Administrator

Hello,

Can you make sure you have "xorg-x11-drv-openchrome" installed? If it is not, can you "yum install" it and restart X? It is a peculiar problem indeed and unfortunately I've got no way of testing Openchrome driver.
Re: xorg server crashes on video playback in stella 6.3 i386 [message #444 is a reply to message #443] Wed, 03 October 2012 06:18 Go to previous messageGo to next message
Haker Defo is currently offline  Haker Defo
Messages: 30
Registered: October 2012
Location: India
Member

Thanks Nux for your quick reply. Yes it is installed. the exact version is "xorg-x11-drv-openchrome-0.2.904-4.el6.i686". By the way i tried booting in 'basic video' mode and tested the video playback, the same crashe occured. Can i upgrade or downgrade xorg or openchrome driver? If yes how? I've been searching the web for any solution to my problem and i've found a couple of links which i think could be the solution but they require compiling driver and i'm not good enough to do it but Nux you can do it. Please check out these links. P.S. According to forum rules i can't use links until i've posted more than 10 messages so i'm attaching a txt file containing those two links. cheers!
Re: xorg server crashes on video playback in stella 6.3 i386 [message #445 is a reply to message #442] Wed, 03 October 2012 07:13 Go to previous messageGo to next message
nux is currently offline  nux
Messages: 1659
Registered: January 2012
Senior Member
Administrator

Hi,

I'll see what I can do. Don't hold your breath. Smile
Re: xorg server crashes on video playback in stella 6.3 i386 [message #446 is a reply to message #442] Wed, 03 October 2012 07:17 Go to previous messageGo to next message
nux is currently offline  nux
Messages: 1659
Registered: January 2012
Senior Member
Administrator

One of the people suggests using mplayer/smplayer with X11 video output instead of xv; have you tried that? It could be a temporary solution.

"The solution incomplete is SMplayer and select option in preference -> Output Driver: X11"
Re: xorg server crashes on video playback in stella 6.3 i386 [message #447 is a reply to message #442] Wed, 03 October 2012 07:27 Go to previous messageGo to next message
nux is currently offline  nux
Messages: 1659
Registered: January 2012
Senior Member
Administrator

I've backported the driver from Fedora Rawhide, should be the latest one, give it a try and let me know how it goes:
http://tmp.nux.ro/xorg-x11-drv-openchrome/xorg-x11-drv-openc hrome-0.3.1-1.el6.nux.i686.rpm
Re: xorg server crashes on video playback in stella 6.3 i386 [message #448 is a reply to message #447] Wed, 03 October 2012 09:36 Go to previous messageGo to next message
Haker Defo is currently offline  Haker Defo
Messages: 30
Registered: October 2012
Location: India
Member

Nux, you are a champ! Thanks a ton! That backported driver solved my problem! Video playback is now perfect! A question, will the future updates change this openchrome driver? If yes how can i make this change permanent? One confession, i was initially confused about whether to download centos or stella. I visited forums of both centos and yours and one thing i noticed was your quick and favourable response to problems and questions posted by users and that made me chose stella over centos. And you have proved my decision right! Thanks again!
Re: xorg server crashes on video playback in stella 6.3 i386 [message #449 is a reply to message #442] Wed, 03 October 2012 14:02 Go to previous messageGo to next message
nux is currently offline  nux
Messages: 1659
Registered: January 2012
Senior Member
Administrator

Well, Stella basically is Centos with some additions, so I don't think it would've mattered. One can install Centos, add nux-dextop repo and you basically have Stella.

Regarding the driver, I don't think it will ever be replaced, and if it will it means it's by a higher version which likely has this bug fixed. I wouldn't worry about it. Just forget about it. Smile
Re: xorg server crashes on video playback in stella 6.3 i386 [message #450 is a reply to message #449] Wed, 03 October 2012 16:44 Go to previous messageGo to next message
Haker Defo is currently offline  Haker Defo
Messages: 30
Registered: October 2012
Location: India
Member

No need to worry about the video playback now! I'm relieved! I can now go ahead and install stella without any worries! All thanks to you Nux! And i know that stella is a remix of centos and you've clearly stated that on stella's home page that base system is centos without any changes. That was the reason for my confusion regarding chosing between stella and centos and as i stated in my previous post that i chose stella over centos because of you Nux! Thanks again! Keep up the great work! By the way i think you need to remix the home page of stell! No offense but it looks a tad too simple! There are people (majority may be) who judge the book by the cover! Stella is a great os and even linux newbie will love it and there are plenty of veteran linux users who are dissatisfied and even angered by the unity, gnome shell and such stupid and all too frequent changes! Stella can be their alternative! As you said somewhere you are not a good marketeer! Change it! Spreat the buzz! Spread stella! Cheers!
Re: xorg server crashes on video playback in stella 6.3 i386 [message #451 is a reply to message #449] Wed, 03 October 2012 16:44 Go to previous messageGo to next message
Haker Defo is currently offline  Haker Defo
Messages: 30
Registered: October 2012
Location: India
Member

No need to worry about the video playback now! I'm relieved! I can now go ahead and install stella without any worries! All thanks to you Nux! And i know that stella is a remix of centos and you've clearly stated that on stella's home page that base system is centos without any changes. That was the reason for my confusion regarding chosing between stella and centos and as i stated in my previous post that i chose stella over centos because of you Nux! Thanks again! Keep up the great work! By the way i think you need to remix the home page of stell! No offense but it looks a tad too simple! There are people (majority may be) who judge the book by the cover! Stella is a great os and even linux newbie will love it and there are plenty of veteran linux users who are dissatisfied and even angered by the unity, gnome shell and such stupid and all too frequent changes! Stella can be their alternative! As you said somewhere you are not a good marketeer! Change it! Spreat the buzz! Spread stella! Cheers!
Re: xorg server crashes on video playback in stella 6.3 i386 [message #452 is a reply to message #442] Wed, 03 October 2012 17:15 Go to previous messageGo to next message
nux is currently offline  nux
Messages: 1659
Registered: January 2012
Senior Member
Administrator

Yeah, I've been told before... I'll try to make it more nicer to watch sometimes in the future. Smile
Re: xorg server crashes on video playback in stella 6.3 i386 [message #453 is a reply to message #452] Wed, 03 October 2012 17:44 Go to previous messageGo to next message
Haker Defo is currently offline  Haker Defo
Messages: 30
Registered: October 2012
Location: India
Member

Looking forward to a revamped stella home page and a marketing savvy Nux! Cheers!

[Updated on: Wed, 03 October 2012 17:45]

Report message to a moderator

Re: xorg server crashes on video playback in stella 6.3 i386 [message #454 is a reply to message #442] Wed, 03 October 2012 17:51 Go to previous message
nux is currently offline  nux
Messages: 1659
Registered: January 2012
Senior Member
Administrator

Eh, I'm not trying to monetise anything; marketing is the least of my problems right now, but you do have a point.

Thanks for all the kind words.
Previous Topic: Cellular Modem Support
Next Topic: Nautilus
Goto Forum:
  


Current Time: Sun Sep 15 19:39:33 BST 2019

Total time taken to generate the page: 0.01414 seconds